Vai al contenuto





Archived

Questa discussione è archiviata e chiusa a future risposte.

jackoverfull

Ubuntu 7.04: provatela!

Recommended Posts

Si mi sarà molto utile...

Devi installare xserver-xgl tramite apt...

sudo apt-get install xserver-xgl

Dopo devi fare:

gksudo gedit /usr/bin/startxgl.sh

Ti si apre l'editor.. e devi inserire:

#!/bin/sh 
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
dbus-launch --exit-with-session gnome-session 
beryl-manager

Salva e chiudi l'editor... digita questo comando per renderlo eseguibile:

sudo chmod +x /usr/bin/startxgl.sh

adesso, devi riaprire l'editor per creare un nuovo tipo di sessione

gksudo gedit /usr/share/xsessions/xgl.desktop

e incollarci dentro paro paro questo:

[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Comment=Start an Xgl Session
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application

Salva il file e puoi riavviare... alla schermata di login, nel menù Opzioni (in basso a sinistra) c'è la voce Scegli tipo di sessione li dovresti trovare XGL....

Ci sarebbe un altro metodo, ma oltre che è più macchinoso... non ti consente di ritornare ad AiGLX se tieni problemi :ghghgh:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


mi hanno detto che la cosa migliore è mettere ubuntu 6.06...poi installarci kde e poi aggiornare alla 7.04.

voi che ne pensate?


È proprio qui sulla terra la mela proibita | e non Dio ma qualcuno che per noi l'ha inventato | ci costringe a sognare in un giardino incantato

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

sono d'accordo; la cosa migliore è installare la 7.04 da zero, meno aggiornamenti di distribuzione fai meno problemi rischi di crearti…


"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Anche perchè GNOME su Ubuntu Feitsy (7.04) ha avuto parecchie modifiche...

Figurati che dal Gnome di ubuntu 6.10 a ubuntu 7.04 che differisce di 0.0.2 versioni... bisogna ricreare la configurazione di Gnome... FIGURATI DA 6.06 a 7.04 che cambia da cosi a cosà.... .P


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Figurati che dal Gnome di ubuntu 6.10 a ubuntu 7.04 che differisce di 0.0.2 versioni... bisogna

a me ha tenuto tutte le impostazioni… :ghghgh:


"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Mi ero dimenticato.. una volta installato XGL non dovrebbero esserci i tasti per spegnere o riavviare linux... ma per questo c'è un modo alternativo :ghghgh:

Facendo tasto dx sul desktop e andando su Crea launcher e mettere come comando da avviare: "sudo /sbin/shutdown -h 0" per lo spegnimento mentre per riavviare "sudo /sbin/reboot" e dopo aver creato questi collegamenti, da terminale digita quanto segue

#visudo

e alla fine del file aggiungi queste righe

vivek localhost= NOPASSWD: /sbin/shutdown -h 0
vivek localhost= NOPASSWD: /sbin/reboot

e salva tutto :ghghgh:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Mi ero dimenticato.. una volta installato XGL non dovrebbero esserci i tasti per spegnere o riavviare linux... ma per questo c'è un modo alternativo :ghghgh:

Facendo tasto dx sul desktop e andando su Crea launcher e mettere come comando da avviare: "sudo /sbin/shutdown -h 0" per lo spegnimento mentre per riavviare "sudo /sbin/reboot" e dopo aver creato questi collegamenti, da terminale digita quanto segue

#visudo

e alla fine del file aggiungi queste righe

vivek localhost= NOPASSWD: /sbin/shutdown -h 0
vivek localhost= NOPASSWD: /sbin/reboot

e salva tutto :ghghgh:

anche qui, all(epoca (ancora sulla 6.10: ora uso aiglx) non ebbi questo problema…


"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

I driver ATI quelli non opensource, non supportano AiGLX...

Mentre i driver ATi opensource, supportano AiGLX ma son lentini :ghghgh:

E allora a ogni problema c'è una soluzione.. se il problema non si ponea... soluzione non serve più :ghghgh:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
I driver ATI quelli non opensource, non supportano AiGLX...

Mentre i driver ATi opensource, supportano AiGLX ma son lentini :ghghgh:

E allora a ogni problema c'è una soluzione.. se il problema non si ponea... soluzione non serve più :ghghgh:

sì, lo so, un mio amico ha lo stesso problema (e per giunta i driver opensource non vanno con la sua scheda)…

per noi utenti ppc il problema non si pone: quando ci va bene la nostra scheda è supportata da quelli open, altrimenti nisba…:P


"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

fatemi capire....... allora a me di estetica piace di più kubuntu............su kubuntu 7.04 è uguale a ubuntu (quindi il cubo integrato) cambia solo l'estetica giusto???? perchè se è così scarico kubuntu 7.04.

insomma ditemi voi


È proprio qui sulla terra la mela proibita | e non Dio ma qualcuno che per noi l'ha inventato | ci costringe a sognare in un giardino incantato

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Allora.. il cubo non è integrato in Kubuntu... però non ti cambia molto perchè basta fare

sudo apt-get install beryl-manager

e ti installi il cubo come se nulla fosse :ghghgh:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

e per mappare al tastiera come su OS X? Cioè fare mela c al posto di ctrl c e mela tab al posto di alt tab? Per alt come tasto per i caratteri speciali ho già risolto, mi mancano gli altir due.


"La risposta è dentro di noi... e però, è sbagliata!"

my blog: http://jeby.blogspot.com

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
altrimenti usi gli fglrx :ghghgh:

non su ppc…

e per mappare al tastiera come su OS X? Cioè fare mela c al posto di ctrl c e mela tab al posto di alt tab? Per alt come tasto per i caratteri speciali ho già risolto, mi mancano gli altir due.

su ubuntu o kubuntu?


"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Si mi sarà molto utile...

Devi installare xserver-xgl tramite apt...

sudo apt-get install xserver-xgl

Dopo devi fare:

gksudo gedit /usr/bin/startxgl.sh

Ti si apre l'editor.. e devi inserire:

#!/bin/sh 
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
dbus-launch --exit-with-session gnome-session 
beryl-manager

Salva e chiudi l'editor... digita questo comando per renderlo eseguibile:

sudo chmod +x /usr/bin/startxgl.sh

adesso, devi riaprire l'editor per creare un nuovo tipo di sessione

gksudo gedit /usr/share/xsessions/xgl.desktop

e incollarci dentro paro paro questo:

[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Comment=Start an Xgl Session
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application

Salva il file e puoi riavviare... alla schermata di login, nel menù Opzioni (in basso a sinistra) c'è la voce Scegli tipo di sessione li dovresti trovare XGL....

Ci sarebbe un altro metodo, ma oltre che è più macchinoso... non ti consente di ritornare ad AiGLX se tieni problemi :ghghgh:

Ho fatto tutto quello che mi hai detto. Ora come faccio a far apparire questo famoso cubo_:gelato:

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Una volta avviato con XGL... devi solo aprire beryl-manager... e una volta fatto, fare tasto destro sull'icona di beryl sull traybar e andare a selezionare Beryl come gestore delle finestre :sediata:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Allora quando seleziono beryl come gestore delle finestre non mi si attiva niente :sediata: Mentre se scelgo compiz almeno le finestre prendono quell'effetto tremolante quando le muovi. Per il cubo 3d?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Vabbè o beryl o compiz, è lo stesso! Il cubo intanto lo devi attivare dalle impostazioni del beryl, anche se solitamente è attivo... e per girare il cubo si tiene premuta la rotella del mouse sullo sfondo del desk e si gira il mouse... o in mancanza di questi, usare Ctrl+mela e girare il mouse... ora non mi ricordo se è Control+mela o Control+Option :mad: comunque te prova :sediata: Può anche essere Control+shif+option e giri il mouse :mad:

Non il macbook a portata di mano, sennò ti dicevo preciso


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Come puoi vedere da questo effetto, usando compiz, dovrebbe tutto fungere per bene. Però la parte superiore della finestra (quella dove ci sono i bottoni per ridurre ad icona ecc) non si vedono quando attivo compiz infatti guarda qua.

La cosa strana è che se invece selziono beryl tutti questi effetti non si vedono :sediata:

Per il cubo invece niente, ho provato di tutto ma non va davvero :mad:

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Io per questo ti dicevo di usare Xgl con beryl.. perchè compiz fà stò scherzo :mad:

Se selezioni beryl, devi aprire il configuratore di beryl.. e attivarli perchè di default sono disattivati tanti effetti :sediata: tra cui il Wobble delle finestre acquose...

E tra questi.. attivi anche il cubo rotante :mad:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Allora, non so perchè, ma ho riprovato ad usare beryl ed ora fa la stessa cosa di compiz. QUindi finestre woopose ma senza bordo superiore. Inoltre forse ho pure capito come funziona il cubo ctrl+alt server per cambiare desktop se poi premo la freccetta in su sembra che le finestre si muovano come in un cubo anche se però il cubo non si vede…se vedono solo le finestre che si muovono lateralmente…Io credo che sia un problema di driver della scheda video. Io ho quelli standard, non li ho toccati proprio. Potrebbe essere che devo scaricare un tipo diverso di driver?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ma perchè devi vedere il desktop e con il cursore sullo sfondo con ctrl+alt spostare il mouse..... Poi unica cosa, provare a ricaricare il desktop manager.. perchè se riesci a vedere glxgears bene è già una cosa...

Piuttosto prova a fare "glx_info" da terminale e dimmi cosa ti esce :sediata:


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Gli ingranaggi si vedono bene.

Mentre per glx:

[email protected]:~$ glx_info

bash: glx_info: command not found

[email protected]:~$ sudo glx_info

Password:

sudo: glx_info: command not found

[email protected]:~$

Il cubo invece niente..ho provato come hai detto tu ma non va..secondo me ci sono problemi con i driver..ho fatto pure un video di quello che vedo e ora vedo se lo riesco a postare.

gagginaspinnata.altervista.org/cubo.mpeg <==== eccolo il video. La qualità non è alta, anzi, non sono riuscito a fare meglio. Almeno cosi vedi la parte superiore delle finestre che manca e come io vedo il cubo (sempre se è questo). Nel video faccio prima partire quello che io penso sia il cubo e dopo invece passo tra un desktop e l'altro per farti vedere la differenza:)

Il video lo sta caricando fra 5 min dovrebbe finire

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

confermo provate la 7.04 è FAVOLOSA.

io che sono completamente inesperto di linux mi sto trovando benissimo.

ho il cubo e le finestre gommose che funzionano (e ho la scheda video schifosa....solo 64mb)

i codec audio me li ha trovati da solo, i programmi sono facilissimi da installare.

provatela


È proprio qui sulla terra la mela proibita | e non Dio ma qualcuno che per noi l'ha inventato | ci costringe a sognare in un giardino incantato

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Eppure da Parallels non mi va... mmm...


www.libertascatenata.it

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ora va...

bisogna dare per l'avvio Live

live vga=771


www.libertascatenata.it

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Ora va...

bisogna dare per l'avvio Live

live vga=771

Te l'avevo detto sopra :popcorn:

x maruzzo:

Guarda, la cosa è strana perchè se imposti Beryl come Window Manager..

prova installando questo:

sudo apt-get install xserver-xgl compiz-gnome libglitz-glx1 libgl1-mesa

Installiamo anche compiz, il vero e proprio window manager pieno di effetti sbalorditivi.

sudo apt-get install compiz-vanilla compiz-vanilla-gnome

Configurazione del sistema

Primo passo: indicare a GDM che vogliamo far partire Xgl, per fare questo modificate /etc/gdm/gdm.conf-custom aggiungendo queste linee sotto [servers]:

[servers]
1=Xgl
[server-Xgl]
name=Xgl server
command=/usr/bin/Xgl :1 -ac -accel glx:pbuffer -accel xv:fbo
flexible=true

Secondo passo: specificare che vogliamo che compiz sia lanciato appena prima di GNOME.

e da qui in poi ti cito una guida:

bisogna compiere alcune semplici operazioni prima di riavviare.

Supponendo che abbiate installato gli ultimi driver ati e quindi abbiate ricavato i deb dal file .run presente sul sito della ati, x una corretta installazione di xgl + compiz avete bisogno di avere una copia di backup del pacchetto:

xorg-driver-fglrx_8.29.6-1_i386.deb

Ok seguendo la guida di felipe avete prima ottenuto l’accelerazione 3d e poi vi avete installato tutti i pacchetti necessari. Quando installate le mesalib però vi vengono rimpiazzati 2 file (/usr/lib/):

libGL.so.1

libGL.so.1.2

Dovete quindi copiare quei file in un posto sicuro e ripristinare quelli forniti dai driver ATI:

sudo mkdir /opt/mesa

sudo cp /usr/lib/libGL.so.1 /opt/mesa/

sudo cp /usr/lib/libGL.so.1.2 /opt/mesa/

sudo dpkg -i –force-overwrite xorg-driver-fglrx_8.29.6-1_i386.deb

Ora al posto di “compiz –replace gconf†da mettere in gnome-session-properties è meglio creare questo script in /usr/bin/

sudo gedit /usr/bin/startcompiz

contenente:

#!/bin/sh

gnome-window-decorator –replace &

DISPLAY=:1 LD_PRELOAD=/opt/mesa/libGL.so.1.2 compiz –replace gconf

(tre righe in tutto), rendere eseguibile:

sudo chmod 755 /usr/bin/startcompiz

e aggiungere a gnome-session-properties semplicemente:

/usr/bin/startcompiz

E’ tutto

Per ottenere i deb della tua distribuzione prima vai da terminale nella cartella che conteine il file .run dei driver ati, e dopo fai questi passaggi

[font=Courier New]sudo chmod +x ati-driver-installer-versione.run
sudo ./ati-driver-installer-versione --buildpkg Ubuntu/feitsy[/font]
[font=Courier New]

[/font]


Il mio sito: www.megaportal.it

Alternativa a Imageshack: www.megaportal.it/imghost

Commenti, suggerimenti, e critiche sono bene accette!

GattoSpammoneâ„¢ Original. Made in Casa mia ^^

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Penso che non sia proprio destino...

[email protected]:~$ sudo apt-get install xserver-xgl compiz-gnome libglitz-glx1 libgl1-mesa

Password:

Lettura della lista dei pacchetti in corso... Fatto

Generazione dell'albero delle dipendenze in corso

Reading state information... Fatto

xserver-xgl è già alla versione più recente.

compiz-gnome è già alla versione più recente.

libglitz-glx1 è già alla versione più recente.

libglitz-glx1 set to manual installed.

Il pacchetto libgl1-mesa non ha versioni disponibili, ma è nominato da un altro

pacchetto. Questo significa che il pacchetto manca, è diventato obsoleto

o è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto libgl1-mesa non ha candidati da installare

[email protected]:~$ sudo apt-get install compiz-vanilla compiz-vanilla-gnome

Lettura della lista dei pacchetti in corso... Fatto

Generazione dell'albero delle dipendenze in corso

Reading state information... Fatto

E: Impossibile trovare compiz-vanilla

[email protected]:~$

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo