Vai al contenuto

Benvenuto nella community di Italiamac Forum

Guest Image

Benvenuto su Italiamac, la più grande comunità AMUG italiana riconosciuta da Apple. La consultazione è libera. Se vuoi anche partecipare attivamente alle discussioni pubblicando post e messaggi puoi iscriverti gratuitamente, avrai molti vantaggi:

  • Pubblicare post, messaggi e richieste di aiuto
  • Fare amicizia e usare i messaggi privati fra utenti
  • Pubblicare annunci di vendita di usato
  • Usare tutte le funzioni della community

ISCRIVITI GRATIS


Change Mode






ArchLinux su MacBook


EmaMacMan

Recommended Posts

  • Risposte 74
  • Created
  • Ultima Risposta
grazie jackoverfull, sono più tranquillo..

prego, figurati.

ora sto manettando con xorg, drivers nvidia e compagnia!

:ghghgh:

Buon smanettamento.:ghghgh:

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

scaricati xorg, drivers scheda video, xfce..

> consiglio di installare i nuovissimi drivers nvidia

> con supporto della GeForce 9400M (versione beta 180)

> con il comando yaourt -S nvidia-beta

(chiaramente yaourt va installato a sua volta, è un package manager alternatio)

Però ho i seguenti problemi con X: :)

... e non funzionano mouse e tastiera!! Qualche suggerimento?

(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.

(WW) Disabling Mouse0

(WW) Disabling Keyboard0

emanuele

Link di questo messaggio
Condividi su altri siti

non sono bluetooth, vero?

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

e con i driver open source andavano?

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

Non ho provato, ho installato i drivers nvidia percè necessito dell'accelerazione e delle funzionalità complete..

Ho scoperto, però, che è la funzionalità di hot-plug delle periferiche che per qualche motivo fa saltare le righe relative a mouse e tastiere di default:

da http://wiki.archlinux.org/index.php/Xorg_input_hotplugging :

"When input hotplugging is enabled, X will purge any devices setup in xorg.conf that are using the kbd and mouse driver.

...

Install the xf86-input-evdev driver, configure hal to use the kbd/mouse drivers anyways or disable input hotplugging. Later versions of xorg-server have xf86-input-evdev as dependency. "

ma sono in crisi.. :)

emanuele

Link di questo messaggio
Condividi su altri siti
Non ho provato, ho installato i drivers nvidia percè necessito dell'accelerazione e delle funzionalità complete..

Ho scoperto, però, che è la funzionalità di hot-plug delle periferiche che per qualche motivo fa saltare le righe relative a mouse e tastiere di default:

da http://wiki.archlinux.org/index.php/Xorg_input_hotplugging :

"When input hotplugging is enabled, X will purge any devices setup in xorg.conf that are using the kbd and mouse driver.

...

Install the xf86-input-evdev driver, configure hal to use the kbd/mouse drivers anyways or disable input hotplugging. Later versions of xorg-server have xf86-input-evdev as dependency. "

ma sono in crisi.. :)

trovato, forse..: http://dottorblaster.it/2008/12/xorg-ma-che-mi-combini/

emanuele

Link di questo messaggio
Condividi su altri siti
Non ho provato, ho installato i drivers nvidia percè necessito dell'accelerazione e delle funzionalità complete..

prova anche con gli oss, se vanno è già un inizio per capire dove sia il problema…

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

Dunque.. ecco il punto:

1) il volume condiviso funzione perfettamente ma ho problemi con i premessi sui files: devo (da OS-X) modificare manualmente e mettere per ciascuno "Lettura/Scrittura" ..perché?

2) Arch ok, ho creato il mio utente, installato alcuni pacchetti utili, xfce parte ed i driver nvidia vedono la GeForce 9400M, a quanto capisco..

ma ho queste segnalazioni sull' errors.log :

Dec 24 09:24:40 arch_ema pci 0000:00:03.5: BAR 0: can't allocate resource

Dec 24 09:24:40 arch_ema i8042.c: No controller found.

Dec 24 09:24:40 arch_ema Error: Driver 'pcspkr' is already registered, aborting...

e queste sul Xorg.0.conf :

(WW) The directory "/usr/share/fonts/TTF" does not exist.

.. mi sembra marginale

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

(II) No APM support in BIOS or kernel

.. mi preoccupa già di più

(II) UnloadModule: "mouse"

(II) UnloadModule: "kbd"

(II) UnloadModule: "mouse"

.. non capisco perchè scarichi i moduli, alla fine

Grazie a chi potrà darmi qualche suggerimento!

Buone feste a tutti.. :rolleyes:

----

Allego una versione accorciata dell' rc.conf :

# LOCALIZATION

#

LOCALE="it_IT.utf8"

HARDWARECLOCK="localtime"

USEDIRECTISA="no"

TIMEZONE="Roma/Europe"

KEYMAP="it"

CONSOLEFONT="lat0-16"

CONSOLEMAP=

USECOLOR="yes"

#

# HARDWARE

#

MOD_AUTOLOAD="yes"

#MOD_BLACKLIST=() #deprecated

MODULES=(forcedeth snd-mixer-oss snd-pcm-oss snd-hwdep snd-page-alloc

snd-pcm snd-timer snd snd-hda-intel soundcore coretemp acpi)

USELVM="no"

#

# NETWORKING

#

HOSTNAME="arch_ema"

eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"

INTERFACES=(eth0)

gateway="default gw 192.168.0.1"

ROUTES=(gateway)

#

# DAEMONS

#

DAEMONS=(syslog-ng network netfs crond)

emanuele

Link di questo messaggio
Condividi su altri siti
Dunque.. ecco il punto:

1) il volume condiviso funzione perfettamente ma ho problemi con i premessi sui files: devo (da OS-X) modificare manualmente e mettere per ciascuno "Lettura/Scrittura" ..perché?

temo proprio che sia normale…

comunque sia puoi farlo anche da linux, da root…

se fosse una partizione condivisa a parte potresti montarla ignorando i permessi, ma con la home eviterei…

ma ho queste segnalazioni sull' errors.log :

Dec 24 09:24:40 arch_ema pci 0000:00:03.5: BAR 0: can't allocate resource

Dec 24 09:24:40 arch_ema i8042.c: No controller found.

Dec 24 09:24:40 arch_ema Error: Driver 'pcspkr' is already registered, aborting...

ce le ho anch'io, tali e quali.

e queste sul Xorg.0.conf :

(WW) The directory "/usr/share/fonts/TTF" does not exist.

.. mi sembra marginale

NOn l'ho notata, ma è decisamente marginale (e magari non ce l'ho proprio: sicuramente dipende dalla distro).

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

(II) No APM support in BIOS or kernel

.. mi preoccupa già di più

Non mi pare che i mac supportino l'acpi…:dance:

(II) UnloadModule: "mouse"

(II) UnloadModule: "kbd"

(II) UnloadModule: "mouse"

.. non capisco perchè scarichi i moduli, alla fine

ma funzionano?

Probabilmente hai dei moduli doppi definiti in xorg.conf…

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti
  • 2 weeks later...

Ciao a tutti.. ecco l'ultimo aggiornamento della situazione:

1) xfce va che è una favola..! :ghghgh:

1) sensors non funziona correttamente: il xfce4-sensors-plugin non mi permette di impostare le barre colorate per la visualizzazione dello stato, anche se la temperatura dei due core (solo quelli) è restituita

3) le ventole non vanno, mi sembra.. ;)

Altri punti sono da risolvere, ma mi premono questi..

Inoltre:

-> se volessi evitare i problemi di privilegi sul volume condiviso, montando la home senza permessi, come posso fare?

-> ho fatto un pacman -S acpi acpid, come suggerito da un collega, poichè al lancio di X era richiesto acpid.. ma che sono di preciso acpi e acpid !?!?!

...

Suggerimenti..!? :ghghgh:

A mia volta sono a disposizione, se posso.. :bubble:

Un grazie particolare a jackoverfull!

emanuele

Link di questo messaggio
Condividi su altri siti
Ciao a tutti.. ecco l'ultimo aggiornamento della situazione:

1) xfce va che è una favola..! :P

:mitra:

1) sensors non funziona correttamente: il xfce4-sensors-plugin non mi permette di impostare le barre colorate per la visualizzazione dello stato, anche se la temperatura dei due core (solo quelli) è restituita

Ho come la sensazione che il supporto alle acpi (ammesso che ci sia) sia una po' diverso che sui comuni pc…Su ubuntu c'è una patch apposita per questo genere di cose, su archlinux non saprei…
3) le ventole non vanno, mi sembra.. :)

Come sopra…

Se non vanno ti converrà chiedere anche sul forum ufficiale: sarebbe parecchio grave come cosa…

Altri punti sono da risolvere, ma mi premono questi..

Inoltre:

-> se volessi evitare i problemi di privilegi sul volume condiviso, montando la home senza permessi, come posso fare?

La home non andrebbe mai montata senza permessi.

In ogni caso per montare un volume (si userà il termine "volume" su linux?:confused:) ignorando i permessi bisogna aggiungere un'opzione al file /etc/fstab

… vorrei solo ricordarmi quale di preciso…:D

-> ho fatto un pacman -S acpi acpid, come suggerito da un collega, poichè al lancio di X era richiesto acpid.. ma che sono di preciso acpi e acpid !?!?!

acpi è la gestione del risparmio energia (ventole, batteria…), acpid è il demone che lo gestisce su linux.

Sui vecchi mac apci non c'era (il risparmio energia era gestito in altro modo), i mac attuali di sicuro riportano al sistema di averlo, ma ho la sensazione che non sia standard (come su molti pc, in realtà).

Suggerimenti..!? :ghghgh:

A mia volta sono a disposizione, se posso.. :gira:

Un grazie particolare a jackoverfull!

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

Ultimissime:

Ho reinstallato tutto, pulito, da capo. :rofl:

(Ringrazio per l'assistenza il mio pazientissimo collega Adrix!)

> ArchLinux, of course

> packetti fondamentali

(tra cui banalmente eject acpi acpid sudo)

> XOrg e Gnome (più agevole come configurazione e più bellino di xfce4..:rofl:)

> gdm come login manager (slim dava problemi..)

> monto l'unità condivisa come sottocartella di home, senza privilegi

> ho aggiunto tutto quello che mi serve, per ora

(tra cui firefox evince ed utility varie di Gnome)

Per quanto riguarda il video, attraverso yaourt ho compilato ed installato i driver nVidia ver. 180.xx con suporto esplicito della scheda 9400M (sono definiti nel repository di yaourt come nvidia-beta), i quali funzionano a meraviglia.

Ho disabilitato tutti i moduli di default che non ritengo necessari, tra cui anche quelli del suono, e non installerò supporto ad accessori quali wireless, webcam, ecc.. in quanto vorrei mantenere il sistema leggero.

!! = > acpi acpid sembrano funzionare, ma ho problemi con sensori e ventole, come già detto.. ci sto lavorando :fiorellino:

La prossima fase sarà l'installazione del software specifico che mi occorre per il lavoro, ovvero compilatori, software per il calcolo, CAD, con relative dipendenze..

Resto a disposizione per chiarimenti, se posso essere utile ben volentieri!

Ciao a tutti.. :rofl:

emanuele

Link di questo messaggio
Condividi su altri siti

Ottimo.;)

Lapsus freudiano! :rolleyes:

No, semplicemente non ne ero sicuro. Ora ho controllato, si usa.:ghghgh:

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

Grazie, molto interessanti soprattutto le parti relative al kernel e alla scheda ethernet, dovrò dare un'occhiata sul mio sistema.;)

"Errore di configurazione di Windows: mouse e tastiera scollegati. Premere F1 per riavviare."

"Assimilation is futile: Microsoft delenda est!"

6/6/2005: è l'inizio della fine.

Home Page | multiXFinder | OpenArena | SuspendNow!

Link di questo messaggio
Condividi su altri siti

Archived

Questa discussione è archiviata e chiusa a future risposte.


×
×
  • Crea Nuovo...

Info

Questo sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego e dichiari di aver letto e di accettare: Privacy Policy Termini di utilizzo