Vai al contenuto





Archived

Questa discussione è archiviata e chiusa a future risposte.

marcopk

Qualcuno programma in C++ con Mac?

Recommended Posts

Ciao a tutti ...

E' da pochissimo tempo che sono un utente Apple e con il mio nuovo iBook 12" vorrei continuare a programmare in C++ !

Avevo gia' postato qualcosina un po' di tempo fa...

Con questo nuovo messaggio spero di trovare qualcuno che programma in C++ ad oggetti e che mi possa dare dei buoni consigli ..... :D:D

( anche perchè tra qualche mese mi comincia un corso di programmazzione ad oggetti in c++ all'universita' e vorrei sfoderare il mio Mac ) :D:D:D:D

Grazie a tutti

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


Guest iDarbert

Uhmmmmm io sto lentamente lasciando il C++ a favore dell'Obj-C ma credo di potermi considerare un novizio di questo linguaggio :D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Io sto facendo la mia tesi di laurea in Ingegneria Informatica sviluppando in C++ (anche se comunque non sono un super-espeto del linguaggio).

Uso come editor Xcode e mi trovo ottimamente (se non per la segnalazione delle parentesi molto scomoda...).

Su mac con OsX puoi sviluppare alla grande...come se fossi sotto Linux !

ciao :D


"If you want to make the world a better place look at yourself and make a change"

www.videomakers.net - Il portale dedicato all' editing video su Pc e Mac

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Vi ringrazio anticipatamente per le vostre risposte ...

Anche io sono uno studente di ingegneria informatica ... ma al secondo anno ...in che facolta' studi ?

Ho iniziato ad utilizzare sia Xcode che CodeWarrior , ma senza nessun risultato in quanto non riesco a far girare nemmeno il piu' classico dei programmini ciao mondo ....

Xcode ... con un codice creato da lui , mi da il seguente erroe ....

/usr/bin/ld : can't create output file: /Users/pg/Documents/Progetti/speriamo (is a directory, errno = 21 )

Avete qualche idea ?????

Per quanto riguarda invece CodeWarrior mi da un altro bellissimo errore ... appena provo a compilare il suo programmino ciao mondo ....

Error: Internal Mach-O importer Error File ( 'ImportMach0.c' Line 2028 unsupporterd unknown reloc type 13 (hunk_type=65535)

:D:D:D

Spero vivamente che mi possiate aiutare perchè non so veramente cosa fare .....:D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Originally posted by marcopk

Anche io sono uno studente di ingegneria informatica ... ma al secondo anno ...in che facolta' studi ?

Io studio a Napoli :D

Non saprei cosa dirti per il tuo problema...che tipo di progetto scegli in Xcode ?

ciao :D


"If you want to make the world a better place look at yourself and make a change"

www.videomakers.net - Il portale dedicato all' editing video su Pc e Mac

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ho provato a reinstallare tutto ma non e' cambiato assolutamente nulla !!!

Secondo voi e' un problema di librerie???

La cosa assurda e' che non compila nemmeno i suoi programmini di base .....

Spero che qualcuno mi possa dare qualche consiglio ....

:D

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Adesso provo a reinstallare Panther .... perchè il tizio che mi aveva venduto il computer secondo me ha fatto un po' di casino !!!

Reinstallo tutto e con calma provo a far girare Xcode e X11 sperando che non mi diano più altri problemi altrimenti non so !!!

:roll:

Se avete qualche altra idea fatemi sapere .....

:lol:

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Anche se ormai sono rimasto da solo a scrivere in questo post .... :cry:

Vi comunico che sono riuscito a risolvere il problema ...

Ho reinstallato Phanter , installando pure X11 dal 3 CD e dopo aver finito di configurare il sistema ho installato Xcode ... e tutto sembra funzionare abbastanza bene ... non mi da piu' gli errori in "Hello World" !!!! :):)

Ciao a tutti ... e grazie per i vostri interventi

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Originally posted by marcopk

Anche se ormai sono rimasto da solo a scrivere in questo post .... :shock:

Vi comunico che sono riuscito a risolvere il problema ...

Ho reinstallato Phanter , installando pure X11 dal 3 CD e dopo aver finito di configurare il sistema ho installato Xcode ... e tutto sembra funzionare abbastanza bene ... non mi da piu' gli errori in \"Hello World\" !!!! :oops::D

Ciao a tutti ... e grazie per i vostri interventi

Io ti aiuterei volentieri... ma per me è arabo!

Mi fa comunque piacere tu abbia risolto il problema! :wink:

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo