Vai al contenuto





Archived

Questa discussione è archiviata e chiusa a future risposte.

_Devil_11_

.bash_profile

Recommended Posts

Salve a tutti.

Ho appena installato MacPort per poi installare gnuplot. Tutto è funzionato a meraviglia!

Purtroppo però, ogni volta che riavvio il terminale devo immettere comandi riportati qui sotto, per poter avere a dispososizione i comandi port e gnuplot.

export PATH=/opt/local/bin:/opt/local/sbin:$PATH
export MANPATH=/opt/local/share/man:$MANPATH
export DISPLAY=:0.0

Ho letto che dovrebbe essere possibile eliminare questo problema aggiungendo le righe di codice sopra riportate al file .bash_profile o a un file simile.

Quel'é esattamente il file da modificare? Dove si trova? Come lo apro? Come vi aggiungo le tre righe di codice? Come salvo le mie modifiche?

Grazie anticipatamente per eventuali risposte.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


guarda tra i file nascosti nella tua home se sono gia' presenti con nome simile:se si' semplicemente aggiungi le righe altrimenti crea tu stesso il file

Digitando il seguente comando di ricerca non ho ottenuto risultati; quindi presumo che il file non esista nemmeno, giusto?

find ~ -type f -iname “.bash*â€

Quindi...come faccio a crearlo e a scriverci dentro?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
$ touch .bash_profile
$ vim .bash_profile

[..] Inserisci le stringhe

:wq
$ 

Riavvia il terminale.

Per creare il file ho usato il seguente comando:

echo 'export PATH=/Users/xxxx/xxxx/:$PATH' >> ~/.bash_profile

E...non mi funziona più niente!

Mi spiego meglio: non funzionano più i vecchi comandi (tipo ls, date, ...). Sembrano funzionare solo quelli relativi alle directory (cd, pwd, ...) ma non li ho provati tutti.

Sei come faccio a ripristinare la situazione?!?

Heeelp!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

perche hai dato quel comando? :ghghgh:

O meglio il comando puo anche andare bene ma hai sbagliato completamente la stringa,al posto di export PATH=/Users/xxxx/xxxx/:$PATH devi dare quelle che tu stesso hai postato nel primo messaggio

Se sai usare nano basta anche che ti sposti nella tua home, dai nano .bash_profile e modifichi il file che hai creato con il comando di prima

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
perche hai dato quel comando? :ghghgh:

O meglio il comando puo anche andare bene ma hai sbagliato completamente la stringa,al posto di export PATH=/Users/xxxx/xxxx/:$PATH devi dare quelle che tu stesso hai postato nel primo messaggio

Se sai usare nano basta anche che ti sposti nella tua home, dai nano .bash_profile e modifichi il file che hai creato con il comando di prima

Ca**ooo! C'ero vicino ma ho cannato in pieno!

Però il gran problema é che ho sputtanato tutto...Nemmeno il comando nano funziona, la pari di vi, vim e emacs...

Come faccio a riparare il danno?!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
/sbin/rm

Non so che sistema hai tu sotto mano, ma qui su Leopard il percorso di rm è /bin/rm

@_Devil_11_

Questo è il percorso completo del comando rm. Usalo per rimuovere il file che hai creato.


Marco - Gallery

MacBook Nero 2.2 GHz Intel Core 2 Duo - 4 GB RAM - Mac OS X 10.6 Snow Leopard

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Non so che sistema hai tu sotto mano, ma qui su Leopard il percorso di rm è /bin/rm

@_Devil_11_

Questo è il percorso completo del comando rm. Usalo per rimuovere il file che hai creato.

Con i percorsi completi ora riesco ad utilizzare i comandi...! E ho quindi eliminato il file .bash_profile.

Ora é tutto normale! =).

Grazie mille!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo