Vai al contenuto

Benvenuto nella community di Italiamac Forum

Guest Image

Benvenuto su Italiamac, la più grande comunità AMUG italiana riconosciuta da Apple. La consultazione è libera. Se vuoi anche partecipare attivamente alle discussioni pubblicando post e messaggi puoi iscriverti gratuitamente, avrai molti vantaggi:

  • Pubblicare post, messaggi e richieste di aiuto
  • Fare amicizia e usare i messaggi privati fra utenti
  • Pubblicare annunci di vendita di usato
  • Usare tutte le funzioni della community

ISCRIVITI GRATIS


Change Mode






[MacPorts] problemi dipendenze e varie info e altri repos


^-H3ad-Tr1p-^

Recommended Posts

salve a tutti

ho installato i macports in quanto mi servirebbero alcuni programmi che utilizzo su linux

per esempio ho provato ad installare DIA,un programma per fare i diagrammi di flusso

volevo sapere un paio di cose sui macport perche' ho riscontrato un problema

dunque: io ho installato i macports ,poi ho installato porticus per avere una gui

ho cercato Dia e ho provato ad installarlo senza l opzione universe che mel avrebbe compilata per intel e G4 o G5 o quello che e'

arrivato alla fine della compilazioni mi ha dato degli errori ed ho visto che eran dipendenze non soddisfatte,e cen'erano veramente tante

volevo sapere se c'era il modo di installare le dipendenze che gli occorrono automaticamente o come devo operare in questi casi

X11 e' installato,non so' se lo devo aggiornare,ma non credo perche' e' un software che si trova nei cd di installazione di leopard per cui crdo che anche gli upgrade,quando disponibili siano gestiti automaticamente dal sistema

che mi dite?

grazie mille

questo l output

Dependencies to be installed: cairo xrender xorg-libX11 xorg-libxcb python26 db46 gdbm gettext ncurses ncursesw openssl readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto glib2 autoconf help2man p5-locale-gettext perl5 perl5.8 m4 automake dbus libtool gtk2 atk gtk-doc docbook-xml docbook-xml-4.1.2 xmlcatmgr docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils p5-xml-parser iso-codes libxslt py26-libxml2 rarian getopt gdk-pixbuf2 jasper jpeg tiff pango Xft2 shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libart_lgpl popt

Configuring db46

Error: db46 requires the Java for Mac OS X development headers.

Error: Download the Java Developer Package from: <https://connect.apple.com/cgi-bin/WebObjects/MemberSite.woa/wa/getSoftware?bundleID=20719>

Error: Target org.macports.configure returned: missing Java headers

Warning: the following items did not execute (for db46): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install

Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log

Error: The following dependencies failed to build: cairo xrender xorg-libX11 xorg-libxcb python26 db46 gdbm gettext ncurses ncursesw openssl readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto glib2 autoconf help2man p5-locale-gettext perl5 perl5.8 m4 automake dbus libtool gtk2 atk gtk-doc docbook-xml docbook-xml-4.1.2 xmlcatmgr docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils p5-xml-parser iso-codes libxslt py26-libxml2 rarian getopt gdk-pixbuf2 jasper jpeg tiff pango Xft2 shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libart_lgpl popt

Error: Status 1 encountered during processing.

To report a bug, see <http://guide.macports.org/#project.tickets>

Executing: /opt/local/bin/port -v install dia

pare che manchino gli headers di java,pero' sul sito apple chiede di registrarsi come sviluppartore

Link di questo messaggio
Condividi su altri siti

Archived

Questa discussione è archiviata e chiusa a future risposte.

×
×
  • Crea Nuovo...

Info

Questo sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego e dichiari di aver letto e di accettare: Privacy Policy Termini di utilizzo