Vai al contenuto





Archived

Questa discussione è archiviata e chiusa a future risposte.

apmarmotta

Doppia scheda di rete e condivisione

Recommended Posts

*Riporto quello che ho postato in un'altra sezione senza avere nessuna risposta... magari qua c'è qualcuno che ci capisce qualcosa ;) *

Ci sto diventando matto... tutto quello che voglio fare è afp e samba su una scheda di rete (192.168.1.3) e internet su un'altra (192.168.1.2)

Entrambe le schede sono perfettamente funzionanti così come tutto il sotto sistema di rete (server-client ecc..) il tutto è configurato in modo statico (preferisco) nelle preferenze l'unica differenza tra le 2 schede è che una ha il gateway (router in lion) impostato e l'altra no, e ovviamente l'indirizzo ip.

In questo modo però tutto il traffico "viaggia" sulla rete 192.168.1.2 afp e samba compresi! E nulla sulla 192.168.1.3! Se imposto il gateway sulla 192.168.1.3 la musica cambia... nel senso che tutto passa sulla scheda 192.168.1.3 compreso ovviamente internet!!!

Si potrebbe risolvere facilmente cambiando sottorete, ma vorrei evitarlo in quanto il server accede direttamente ad internet utilizzando la sottorete del router, cambiare la sua sottorete vorrebbe dire togliergli la possibilità di connettersi ad internet, all'access point, a gli altri pc ecc....

Che casino! Ma non si può semplicemente "dire" a lion di usare l'indirizzo 192.168.1.3 per la condivisione documenti e 192.168.1.2 per l'accesso ad internet? Sul lato server (netatalk) non mi pare ci sia niente di utile in tal senso....

Volevo aggiungere anche che se imposto il gateway in entrambe le schede, osx fa come gli pare :shock: una volta mi ritrovo l'afp sulla scheda 192.168.1.2, riavvio e mi ritrovo afp sulla scheda 192.168.1.3.... internet invece è sempre sulla scheda con piu priorita nelle preferenze di rete.

P.S. afp lo "monto" con applescript al boot ("mount volume" ecc...)

Conf di rete:

Mac:

192.168.1.3 (1000mbps)

192.168.1.2 (100mbps)

Server:

192.168.1.25 (1000mbps)

Router/gateway

192.168.1.1 (100mbps)

Piu altri pc e periferiche sempre sulla 192.168.1.x (wifi compreso)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


Anche se non ci sto credendo forse ho risolto :ghghgh:

Ho spostato la 192.168.1.2 in 192.168.2.2 mettendola che scheda con maggiore priorità. Ovviamente in quella sottorete la scheda era sola ed isolata.... allora ho modificato il netmask del router/adsl con 255.255.0.0 Ora navigo con la scheda 100mps!!!! :P le condivisioni invece sono sulla rete 192.168.1.x e li ci restano utilizzando la scheda gigabit!

Avro scoperto l'uovo di colombo o ho fatto una caxxxx? :rolleyes: Per ora sembra funzionare anche se stranamente la rete 192.168.1.x riesce a "pingare" la 192.168.2.x ..... ma avendo il server un netmask 255.255.255.0 non dovrebbe non vedere le altre sottoreti? Boooo :confused: avrò forse problemi di loop???

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo