Vai al contenuto

Benvenuto nella community di Italiamac Forum

Guest Image

Benvenuto su Italiamac, la più grande comunità AMUG italiana riconosciuta da Apple. La consultazione è libera. Se vuoi anche partecipare attivamente alle discussioni pubblicando post e messaggi puoi iscriverti gratuitamente, avrai molti vantaggi:

  • Pubblicare post, messaggi e richieste di aiuto
  • Fare amicizia e usare i messaggi privati fra utenti
  • Pubblicare annunci di vendita di usato
  • Usare tutte le funzioni della community

ISCRIVITI GRATIS


Change Mode






Copia file e file in uso, sempre!


Recommended Posts

Ciao a tutti!

 

scusate il disturbo e probabilmente la domanda stupida, ma perchè ogni qualvolta tento di copiare un file, arriva a fine copia e si stoppa dicendomi che file risulta in uso?? è snervante! ho tentato con un software che esegue il comando lsof ed eventualmente permette di sbloccare i file aperti, ma ogni volta non risulta nulla!

 

scusate l'ignoranza ma non sono proprio abituato a queste operaziono con il mac! grazie mille!

Link di questo messaggio
Condividi su altri siti

non mi viene in mente niente. ti posso solo dire che non è normale perchè a me non è mai successo.

prova a scrivere qui e su google l'errore preciso che ti da (parola per parola).

qui perchè magari qualcuno riesce a trovare la soluzione su google perchè se nessuno ci riesce qui magari ci riesci tu.

Link di questo messaggio
Condividi su altri siti

Ciao! 

 

il messaggio recita "non posso completare l'operazione perché l'elemento X è in uso"

 

su google trovo solo persone che non riescono a cancellare i file, non a copiarli, quindi le soluzioni non mi sono utili purtroppo, grazie a tutti :)

Link di questo messaggio
Condividi su altri siti

Invece di copiare provare a salvare:

- file aperto, "Salva col nome" nella nuova posizione desiderata (magari con diverso nome);

- se funziona, eventualmente ancora "Salva col nome" con lo stesso nome originale e nella posizione primitiva sostituendo pertanto il file.

Inviato dal mio telefono fisso di casa, quello con il disco combinatore

Link di questo messaggio
Condividi su altri siti

Non so che dirti non mi è mai capitato, in particolare con la copia che teoricamente non dovrebbe dare problemi anche se un file è in uso.

 

Io proverei con copia tasto destro, incolla.

oppure con trascinamento tenendo premuto o alt o cmd.

 

Su google neanch'io ho trovato soluzione.

 

Però tanto per provare (visto che è un problema grave) puoi vedere se ti da lo stesso problema con il terminale (a volte può servire anche a questo).

ti copio invollo una delle tante guide.

  • Copiare i file

Il comando per copiare il file è il seguente:

Il comando “cp†prevede molte opzioni, vediamo le più utilizzate.

cp NOME_FILE CARTELLA_DESTINAZIONE (o nome file in caso si voglia creare una copia del file nello stesso punto)

  • cp -R : effettua la copia ricorsiva, ovvero copierà anche le directory e il loro contenuto;
  • cp -p : vengono mantenuti tutti gli attributi (data, permessi etc), se possibile verranno mantenuti anche utente e gruppo di appartenenza; i link simbolici non saranno copiati, nel caso in cui sia specificata l’opzione -R;
  • cp -P : con questa opzione, non sono considerati i link simbolici;
  • cp -L : verranno considerati anche i link simbolici.

vedi se con questo comando ti da problemi, se non te ne da è un problema legato al finder, se no non saprei dirti potrebbe anche essere il disco

Link di questo messaggio
Condividi su altri siti

grazie a tutti per le risposte!

 

ho provato un cp -R di una cartella intera e in effetti ha funzionato.. quindi il problema potrebbe essere localizzato sul finder? 

 

Sì dovrebbe essere un problema del finder da quando hanno introdotto le schede hanno introdotto un po' di problemi generali e qualcuno specifico.

Il mio consiglio è a questo punto se hai intenzione di risolvere il problema di provare a reinstallare (senza cancellare i dati) mavericks.

Se va tutto bene, c'è stato solo un problema nell'installazione del sistema. Se va male potrai tentare con un'installazione pulita.

 

Altri metodi per risolvere non mi vengono in mente... potresti vedere se resettando PRAM, e facendo ripartire il finder e riparando i permessi e il disco smette di darti problemi ma non ti aspettare niente perchè se hai un finder "corrotto" questi procedimenti non risolvono.

 

Queste sono tutte ipotesi, se sei sotto garanzia la cosa più conveniente è fare un backup e usufruire dell'assistenza apple che se va bene in meno di 24h ti risolve il problema (a me hanno cambiato lo schermo in meno di un giorno, sono andato all'Apple store di torino, se ne hai uno vicino ti conviene andare lì piuttosto che in un'Apple reseller).

Se sei fuori garanzia, quando avrai provato tutto, ti conviene andarci comunque. se non è un problema hardware dovresti cavartela con poco (magari ti aiutano anche a costo zero se è un problema di mavericks).

Prima di andarci ti conviene fare l'harware test

Link di questo messaggio
Condividi su altri siti

Da quando c'e' maverick anche io salutariamente incappoo in questo problema, di solito lo risolvo cambiando estensione al file, copiandolo e poi rimettendo l'estensione originale, speriamo si affrettino a fixare questo problema con un aggiornamento.

Link di questo messaggio
Condividi su altri siti

Da quando c'e' maverick anche io salutariamente incappoo in questo problema, di solito lo risolvo cambiando estensione al file, copiandolo e poi rimettendo l'estensione originale, speriamo si affrettino a fixare questo problema con un aggiornamento.

Forse allora è un problema che affligge uno o più modelli di mac perchè io non lo rilevo.

il mio è un macbook pro retina 15'' del 2012.

Link di questo messaggio
Condividi su altri siti

Io ho un macmini late 2011 (o 2010 sinceramente non ricordo) e ho questo problema da quando uso Mavericks, forse l'interfaccia "a moduli" causa qualche problema davvero? 

proverò a reinstallare il SO e vi faccio sapere (se vi interessa), grazie a tutti!!!

Link di questo messaggio
Condividi su altri siti

Prima di tutto calcolate che se non fate un copia del file il problema non si pone, di solito la gente tende a cancellare i doppioni non ha duplicarli.

A me lo da saltuariamente (1 volta su 10 diciamo), me ne accorgo perche sposto o copio parecchi file sulla mia nas.

Questo problema e' stato introdotto con maverics prima non me lo aveva mai fatto ne sono sicuro.

Difatto riesco ad ovviare a questo problema ma spero che lo fixino al piu presto.

Link di questo messaggio
Condividi su altri siti

Ciao Trip3, in realtà a me il problema si presenta anche quando sposto un file, invece di copiarlo! Anche io interagisco molto con il nas e mi sono accorto del problema in questo contesto, anche se con una frequenza maggiore rispetto alla tua! 

 

appena riesco provo una sovrainstallazione di mavericks e vi dico! grazie!

Link di questo messaggio
Condividi su altri siti

Ciao Trip3, in realtà a me il problema si presenta anche quando sposto un file, invece di copiarlo! Anche io interagisco molto con il nas e mi sono accorto del problema in questo contesto, anche se con una frequenza maggiore rispetto alla tua! 

 

appena riesco provo una sovrainstallazione di mavericks e vi dico! grazie!

Si anche a me spostando o copiando il file (video) e sicuro 100% dipende da maverick, ma ripeto siamo ad 1 su 10 massimo 2, spero che fixino al più presto, comunque se rinomini il file cambiando estensione sopperisci al problema, la fregatura sta che l'impossibilita di spostarlo o copiarlo te lo da alla fine del trasferimento.

Link di questo messaggio
Condividi su altri siti
  • 1 month later...

Mi e' ance successo che al secondo tentativo la copia o spostamento (non andato a buon fine al primo tentativo) vada a buon fine (mistero), cmq mavericks ha rotto il c4zzo, questa e' una menata mica da poco.

E come se il sistema operativo, si facesse i c4zzi del file che ho appena scaricato senza che io gli abbia detto di farseli, e bade bene parlo di file scaricati all'interno di cartella esclusa dal time machine.

Inizialmente avevo anche pensato al fatto che vlc o quicktime lavorassero in back ground su tali file senza essere lanciati ma ci capisco troppo poco in osx per dimostrare questa mia teoria, ed i difatto, non avendo mai avuto un problema durante 1 anno intero di uso di mountain lion ho scaricato giustamente la colpa su maverick.

 

Ora che ho una nuova nas in arrivo penso che faro' scaricare tutto quello che mi serve direttamente su stessa usando i client torrent proprietari.

Sara un caso ma sto problema me lo da esclusivamente con .mp4 gli .mkv va lisci per ora forse solo 1 una sola volta non ricordo di preciso.

 

Se avete altre idee son qua, anche se non penso che potremmo risolvere da soli questo problema.

Link di questo messaggio
Condividi su altri siti
  • 2 weeks later...

Ragazzi anche a me stesso problema con Mavericks.

 

Ancora niente soluzioni?  :mad:  :mad:

 

Io per ora sto ovviando al problema sbloccando i file da spostare.

 

Per capirci, tasto destro, ottieni informazioni e poi sbloccare il lucchetto in basso a destra.

Chiede la password di amministratore.

 

Una volta sbloccato il file da spostare l'errore non appare più! Mistero di Mavericks   :shock:

Modificato da shockato
Link di questo messaggio
Condividi su altri siti
  • 8 months later...

Ciao.

Stesso identico problema... sia su maverick che Yosemite..

A volte quando tento di copiare un file dal mac al nas salta fuori questo messaggio.

In genere facevo un "duplica" e riprovavo con il file copiato e funzionava..

oggi nulla .. allora ho riavviato .. ma nulla..

alla fine ho aperto il file: e dal menu - File - Sposta in ... ha funzionato.

Comunque è una cosa che mi capita solo quando copio un file da mac a NAS..

speriamo ci sia una soluzione..

Link di questo messaggio
Condividi su altri siti

Conosco il problema ma non mi è mai successo. Sembra un bug del Finder , solo che non ho capito perché non succede a tutti !!!

Anche via AFP lo fa ancora? Avete provato tutti i protocolli di rete ?

Inviato dal mio iPhone 6 utilizzando Tapatalk

iMAC 21" intel i3, 8 gb ram & iPhone 6 & iPad Mini 3

Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo