Vai al contenuto





JumpinJack

Problema High Sierra ed interfaccia audio esterna

Recommended Posts

L'aggiornamento a macOS High Sierra 10.13.2 ha posto una problematica per i possessori di una interfaccia audio esterna della ditta americana M-Audio, denominata "FastTrack Pro", ma potrebbe essere simile per chi possiede interfacce audio di altra marca ma comunque un po' vecchie di età!

Questa è infatti un'interfaccia audio semi-professionale nata più di dieci anni fa ed è sempre stata supportata nativamente dalla Apple nelle varie versioni di macOS che si sono succedute in tutti questi anni, fino ad ora.

 

Precisamente fino alla versione 10.13.1 del sistema operativo della mela, "High Sierra", tutto funzionava alla perfezione, ma con il nuovo aggiornamento 13.2 uscito il 7 dicembre, tra le varie modifiche è stato apportato un miglioramento della compatibilità con alcuni dispositivi audio USB di terze parti. Questo indica, probabilmente, che nel migliorare la compatibilità con sempre più nuovi, particolari ed interessanti dispositivi, hanno scelto (se non addirittura avuto necessità) di non supportare più sistemi audio di una certa età. Infatti il dispositivo citato all'inizio, che fu messo in commercio se non erro nel 2006, ovvero più che decennale, non è più supportato.

 

Per concludere: se siete possessori ed utilizzatori di un'interfaccia audio "di una certa età", come la M-Audio FastTrack Pro, è consigliabile NON aggiornare High Sierra e restare alla versione 10.13.1, e su "Preferenze di Sistema > App Store" è consigliabile assicurarsi che non sia selezionato "Installa aggiornamenti macOS", o ancora meglio deselezionare "Scarica gli aggiornamenti disponibili in background".

Se invece avete già eseguito l'aggiornamento a 13.2, ma avete ancora l'app d'installazione che avevate precedentemente scaricato dall'App Store prima dell'aggiornamento (ovvero versione 10.13 o 10.13.1), potete risolvere eseguendo nuovamente "l'aggiornamento" (per così dire) con quell'applicazione: il risultato sarà un "downdate" da 10.13.2 a 10.13.1 (o 10.13)!

 

Lo stesso argomento è trattato nel forum ufficiale Apple Support (in inglese): https://discussions.apple.com/thread/8191481

 

Per gli amministratori del Forum: molto probabilmente sto commettendo un errore nel pubblicare questo "avviso" in questa sezione del Forum. Spostatelo pure nella sezione che considerate più consona, il mio intento è solo avvisare persone che ne possano avere necessità! Grazie!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


Nel forum ufficiale Apple Support il problema è stato segnalato da circa un migliaio di utenti, e dalle varie testimonianze nei commenti sembrava che la versione 10.13.4 avesse finalmente risolto il problema. Purtroppo diversi hanno segnalato nuovamente grane con la 10.13.5, ergo sembrava necessario attendere ancora.

Alla fine la versione 10.13.6 sembra aver finalmente risolto. Io stesso ho effettuato l'aggiornamento e tutto sembra funzionare di nuovo normalmente. Ottimo!

 

 

working1.jpg

Modificato da JumpinJack

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

buonasera, purtroppo smentisco il fatto che la versione 10.13.6 abbia definitivamente risolto il problema in quanto ho la suddetta versione e la ia fast track ancora non vule saperne di funzionare, anzi, cosa ancora più strana, viene rilevata come ingresso/uscita midi, ma non audio..potete aiutarmi? grazie!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 9/1/2020 at 19:44, Matteo Rioli dice:

buonasera, purtroppo smentisco il fatto che la versione 10.13.6 abbia definitivamente risolto il problema in quanto ho la suddetta versione e la ia fast track ancora non vule saperne di funzionare, anzi, cosa ancora più strana, viene rilevata come ingresso/uscita midi, ma non audio..potete aiutarmi? grazie!


Sono piuttosto sorpreso, soprattutto considerando che io ho continuato tranquillamente ad aggiornare macOS e sono attualmente alla versione 10.15.2, tutto questo senza mai problemi! 
Mi dispiace, l’unica cosa che posso suggerire è cercare di aggiornare il sistema operativo alla versione più recente possibile, per quel che il Mac può permettere, e se per caso si sta usando il driver ufficiale scaricato dal sito della Avid, suggerisco di disinstallarlo perché macOS gestisce il dispositivo tranquillamente (anzi, addirittura meglio!) senza!!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo