Vai al contenuto





RBN

Lingua Safari

Recommended Posts

Salve a todos! Piccolo fastidio col buon safari! In seguito all'arrivo di un malware il suddetto programma ha cambiato lingua in inglese.😫 Ho eliminato il malware, eseguito scansione col Malwarebytes, un'altra con EtreCheck e risulta tutto regolare, ma Safari resta in lingua inglese sia nelle impostazioni che in tutte le voci sulla barra.😦 La lingua e la regione nelle preferenze di sistema del mio Netbook pro però sono in settate su Italia. Il fastidio è circoscritto a Safari.🙄🤔 Sapreste dirmi come risolvere cortesemente?😅

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


Hai verificato le impostazioni di safari e del tuo sistema operativo, hai provato a verificare se il malware è stato cancellato e non si ripresenti ogni volta che apri safari. 

 

  • Mi piace 1

I veri problemi dei computer stanno tra la sedia e la tastiera.   Rost

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Sei ancora infetto sicuro, controlla meglio con Etrecheck.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Salve, io tenterei il ripristino di Safari:

 

  1. Chiudere Safari
  2. Dal Finder seleziona nel menu "Vai" tenendo premuto "Alt" seleziona "Libreria"
  3. Sposta nel cestino la cartella Safari
  4. Torna a "Libreria" (Punto 2), apri la cartella "Saved Application State" spostare la cartella "com.apple.Safari.savedState"
  5. Torna a "Libreria" (Punto 2), apri la cartella "Caches" elimina tutte le cartelle con il nome "com.apple.Safari"
  6. Torna a "Libreria" (Punto 2), apri la cartella "Cookies" elimina il file "com.apple.Safari.SafeBrowsing.binarycookies
  7. Torna a "Libreria" (Punto 2), apri la cartella "Preferences" elimina qualsiasi file che ha il nome "com.apple.Safari"
  8. Torna a "Libreria" (Punto 2), apri la cartella "Internet Plug-Ins" elimina eventuali plug.in presenti
  9. Apri "Macintosh HD" cartella "Libreria" apri la cartella "Internet Plug-ins" ed elimina eventuali plug-in ad eccezione dei seguenti file: Default.Browser.plugin, iPhotoPhodcast.pluging, Quartz Composer.webplugin e QuickTime Plugin.plugin (questi NON devono essere eliminati).

Fonte: QUI

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Tentar non nuoce...

 

Preferenze di Sistema... > Lingua scegli "inglese". :DD

 

Riavvii.

 

Preferenze di Sistema... > Lingua scegli "italiano".

 

Riavvii.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
4 ore fa, ro.st dice:

Hai verificato le impostazioni di safari e del tuo sistema operativo, hai provato a verificare se il malware è stato cancellato e non si ripresenti ogni volta che apri safari. 

 

Come faccio a verificarlo?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
3 ore fa, Elliot dice:

Sei ancora infetto sicuro, controlla meglio con Etrecheck.

Ciao Elliot! Boh da quel che vedo Etrecheck mi dice che non rivela problematiche!🤔

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, AntoninoBattiato dice:

Salve, io tenterei il ripristino di Safari:

 

  1. Chiudere Safari
  2. Dal Finder seleziona nel menu "Vai" tenendo premuto "Alt" seleziona "Libreria"
  3. Sposta nel cestino la cartella Safari
  4. Torna a "Libreria" (Punto 2), apri la cartella "Saved Application State" spostare la cartella "com.apple.Safari.savedState"
  5. Torna a "Libreria" (Punto 2), apri la cartella "Caches" elimina tutte le cartelle con il nome "com.apple.Safari"
  6. Torna a "Libreria" (Punto 2), apri la cartella "Cookies" elimina il file "com.apple.Safari.SafeBrowsing.binarycookies
  7. Torna a "Libreria" (Punto 2), apri la cartella "Preferences" elimina qualsiasi file che ha il nome "com.apple.Safari"
  8. Torna a "Libreria" (Punto 2), apri la cartella "Internet Plug-Ins" elimina eventuali plug.in presenti
  9. Apri "Macintosh HD" cartella "Libreria" apri la cartella "Internet Plug-ins" ed elimina eventuali plug-in ad eccezione dei seguenti file: Default.Browser.plugin, iPhotoPhodcast.pluging, Quartz Composer.webplugin e QuickTime Plugin.plugin (questi NON devono essere eliminati).

Fonte: QUI

 

Ciao AntoninoBattiato! Ma se ripristinassi Safari, mi si cancellerebbero tutti i preferiti e i segnalibri!😖 Cercavo una soluzione meno drastica! 😅

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, 167-761 dice:

Tentar non nuoce...

 

Preferenze di Sistema... > Lingua scegli "inglese". :DD

 

Riavvii.

 

Preferenze di Sistema... > Lingua scegli "italiano".

 

Riavvii.

Ciao 167-761! Dici che è così semplice?😆

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ho notato che continuo a ricevere anche notifiche in inglese che portano a siti fake (riguardanti un fasullo download di Adobe).🤦‍♂️

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, RBN dice:

Ciao AntoninoBattiato! Ma se ripristinassi Safari, mi si cancellerebbero tutti i preferiti e i segnalibri!😖 Cercavo una soluzione meno drastica! 😅

 

Puoi salvarli su iCloud oppure, selezionarli e copiarli in una cartella.

 

Ho messo quella procedura perché un altro utente in questo thread - Italiamac Forum ha risolto così. 

 

Su altri siti consigliano di reinstallare macOS (da non confondere con ripristinare), altri consigliano di installare un aggiornamento combo (il download puoi farlo direttamente dal sito Apple).

 

Modificato da AntoninoBattiato

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
14 ore fa, AntoninoBattiato dice:

 

Puoi salvarli su iCloud oppure, selezionarli e copiarli in una cartella.

 

Ho messo quella procedura perché un altro utente in questo thread - Italiamac Forum ha risolto così. 

 

Su altri siti consigliano di reinstallare macOS (da non confondere con ripristinare), altri consigliano di installare un aggiornamento combo (il download puoi farlo direttamente dal sito Apple).

 

Ho provato a ripristinare Safari come da te consigliato seguendo tutti i passi ma la situazione non cambia!😣 quasi quasi reinstallo macOS!😁

  • Mi piace 1

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
19 ore fa, 167-761 dice:

Tentar non nuoce...

 

Preferenze di Sistema... > Lingua scegli "inglese". :DD

 

Riavvii.

 

Preferenze di Sistema... > Lingua scegli "italiano".

 

Riavvii.

 

 

quello che avrei fatto io.


 La supposizione è la madre di tutte le cazzate.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
17 minuti fa, Giuca dice:

 

 

quello che avrei fatto io.

Ciao Giuca! Vabbè in effetti tentar non nuoce....😁

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
25 minuti fa, Giuca dice:

 

 

quello che avrei fatto io.

Non è cambiato nulla anche con questa operazione! 😅

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ri-installa il SO su se stesso.

  • Mi piace 1

 La supposizione è la madre di tutte le cazzate.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, Giuca dice:

ri-installa il SO su se stesso.

E' ciò che sto facendo infatti! Grazie Giuca!🙂

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

E niente! Pur reinstallando il sistema operativo rimane in inglese!😨😞😑

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

mmm...

 

Prova questo comando da Terminale:

defaults write com.apple.Safari AppleLanguages '(it)'
Modificato da AntoninoBattiato

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Io ho risolto con Language Switcher è un piccolo programma gratuito, una volta installato, si deve andare su safari e dirgli di mettere la lingua italiana, poi si dovrà aprire, successivamente, con questo nuovo simbolo di safari, ma funziona perfettamente. Dopo mesi di caos ho risolto. Spero sia definitivo come cosa e mi auguro che nel prossimo aggiornamento sia risolto da Mac il problema.

  • Non mi piace 1

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo