Vai al contenuto

Benvenuto nella community di Italiamac Forum

Guest Image

Benvenuto su Italiamac, la più grande comunità AMUG italiana riconosciuta da Apple. La consultazione è libera. Se vuoi anche partecipare attivamente alle discussioni pubblicando post e messaggi puoi iscriverti gratuitamente, avrai molti vantaggi:

  • Pubblicare post, messaggi e richieste di aiuto
  • Fare amicizia e usare i messaggi privati fra utenti
  • Pubblicare annunci di vendita di usato
  • Usare tutte le funzioni della community

ISCRIVITI GRATIS


Change Mode






Recommended Posts

Ciao mi chiamo Mariagrazia, grazie a chi può aiutarmi. Ho fatto una kzzata, ho aggiornato Adobe Flash Player, sicuramente da qualche sito del kaktus. Quando me ne sono accorta, la home page é diventata fissa "weknow.ac", non posso cambiarla in preferenze-homepage. Safari é in inglese, in preferenze-lingua e zona c'é italiano, ma non é così 😟 Ho fatto girare malwarebytes, ha trovato problemi ed eliminati, ma non é cambiato nulla. Se mi date il permesso posso postare il report di etrecheck, grazie ditemi se posso

Link di questo messaggio
Condividi su altri siti

In realtà, come ti sarai accorta, NON era un aggiornamento di Adobe Flash Player.

 

Non so dirti come ripristinare il tuo Mac, ma il tuo problema è già capitato ad altri qui sul forum, e sarebbe utile per tutti trovare una soluzione.  Va benissimo se copi e incolli qui il report di Etrecheck, che lo esaminiamo. Vai a vedere una cosa: in "Preferenze di Sistema" ti trovi un pannello "Profili" o "Profiles"? Perchè di norma non c'è, e puo' essere il punto di appoggio per il castello di adware/malware che ti sei installata. Se c'è, prova ad aprirlo e posta la schermata (cmd maiusc 4) di quel che vedi.

 

Ciao

  • Mi piace 1
Link di questo messaggio
Condividi su altri siti

Bene.

15 ore fa, Mariagrazia Cado dice:

Quando me ne sono accorta, la home page é diventata fissa "weknow.ac", non posso cambiarla in preferenze-homepage.

In quale browser? Safari? Firefox? Chrome? O tutti?

 

Prova ad avviare in "safe mode" (tasto maiuscole tenuto premuto -lungamente- all'accensione) e vedi se puoi modificare la pagina di ricerca.

  • Mi piace 1
Link di questo messaggio
Condividi su altri siti

167-761 posso proporti come sindaco di italiamac? grazie per la tua gentilezza, non é che tutti si sbattono per i novellini. Ho risolto con apple. Posto i comandi che mi hanno dato e le istruzioni che potranno servire ad altri. So che tu ne farai tesoro per aiutare. Mi hanno fatto rifare Malwarebytes che non ha trovato niente, l'avevo fatto girare ieri. Mi hanno fatto controllare "preferenze di sistema-profili" come mi avevi consigliato tu e l’avevo vuotato, in Safari-preferenze-generali, mi hanno fatto vuotare estensioni. Mi hanno fatto aprire il terminale e dare questo comando    defaults delete ~/Library/Preferences/com.apple.Safari.plist AppleLanguages    Non è successo niente!! Temevo di dover ripristinare il Mac, ho fatto il backup e ho richiamato. Ho scoperto che per la mia versione, Sierra 10.13.4 ci voleva un altro comando     defaults delete com.apple.Safari AppleLanguages

 

Grazie, grazie di tutto 😍

 

 

Link di questo messaggio
Condividi su altri siti

Buonasera, ho riscontrato lo stesso problema ma seguendo i passi qua indicati non è cambiato niente. Ho lo stesso problema dell'inglese purtroppo. Ho provato ma non mi prende nessuno dei comandi lanciati dal terminale (ho Mojave però)

Modificato da Sharp_m8
Link di questo messaggio
Condividi su altri siti
  • 2 weeks later...
  • 2 weeks later...

Ciao a tutti. Poiché mi son trovato nella situazione di mceleste e Sharp_m8, cioè non sono riuscito a risolvere con i suggerimenti (preziosi) di Mariagrazia, a cui vanno i miei più sentiti ringraziamenti, spiego come ho risolto finalmente questa schifezza di weknow, che mi stava facendo venire l'orticaria.

In realtà sarebbe stato più elegante modificare il comando nel terminale, ma non sono molto esperto. Allora ho fatto così.

Ho aperto Finder e dal menu ho cliccato su VAI --> Libreria e ho cancellato nella cartella Safari il file com.Apple.Safari.plist, dopodichè ho riavviato Safari, che è ricomparso nella sua veste iniziale, in Italiano, anche se con tutta la configurazione da rifare.

In precedenza avevo tolto il maledetto trojan (che aveva infettato anche Chrome) installando Avast, antivirus gratutito, fatto girare per una notte e un giorno.

Grazie a tutti.

Link di questo messaggio
Condividi su altri siti
  • 3 weeks later...
Il 10/4/2019 at 00:03, Massimo Borelli dice:

Ciao a tutti. Poiché mi son trovato nella situazione di mceleste e Sharp_m8, cioè non sono riuscito a risolvere con i suggerimenti (preziosi) di Mariagrazia, a cui vanno i miei più sentiti ringraziamenti, spiego come ho risolto finalmente questa schifezza di weknow, che mi stava facendo venire l'orticaria.

In realtà sarebbe stato più elegante modificare il comando nel terminale, ma non sono molto esperto. Allora ho fatto così.

Ho aperto Finder e dal menu ho cliccato su VAI --> Libreria e ho cancellato nella cartella Safari il file com.Apple.Safari.plist, dopodichè ho riavviato Safari, che è ricomparso nella sua veste iniziale, in Italiano, anche se con tutta la configurazione da rifare.

In precedenza avevo tolto il maledetto trojan (che aveva infettato anche Chrome) installando Avast, antivirus gratutito, fatto girare per una notte e un giorno.

Grazie a tutti.

 

Il 12/3/2019 at 16:20, Mariagrazia Cado dice:

167-761 posso proporti come sindaco di italiamac? grazie per la tua gentilezza, non é che tutti si sbattono per i novellini. Ho risolto con apple. Posto i comandi che mi hanno dato e le istruzioni che potranno servire ad altri. So che tu ne farai tesoro per aiutare. Mi hanno fatto rifare Malwarebytes che non ha trovato niente, l'avevo fatto girare ieri. Mi hanno fatto controllare "preferenze di sistema-profili" come mi avevi consigliato tu e l’avevo vuotato, in Safari-preferenze-generali, mi hanno fatto vuotare estensioni. Mi hanno fatto aprire il terminale e dare questo comando    defaults delete ~/Library/Preferences/com.apple.Safari.plist AppleLanguages    Non è successo niente!! Temevo di dover ripristinare il Mac, ho fatto il backup e ho richiamato. Ho scoperto che per la mia versione, Sierra 10.13.4 ci voleva un altro comando     defaults delete com.apple.Safari AppleLanguages

 

Grazie, grazie di tutto 😍

 

 

Ragazzi, in Mojave non trovo queste cartelle 😅

 

Link di questo messaggio
Condividi su altri siti

 

Il 1/5/2019 at 12:12, mic_san dice:

 

Ragazzi, in Mojave non trovo queste cartelle 😅

 

Salve ragazzi, anche noi ho avuto lo stesso problema ma poi ho risolto con assistenza apple. in sostanza mi hanno spiegato che il malware fa tutte le modifiche di cui ha già parlato  Mariagrazia (estensioni, profili, ecc) ed il fatto che rimanga in lingua inglese dopo averle rimosse è solo un errore nel registro di safari ( il malware sovrascrive il registro). quindi mi hanno dato il comando da mettere in terminale per Mojave,. dopo aver aggiunto terminale da preferenze di sistema, sicurezza e privacy, privacy.

 

fatto questo bisogna aprire terminale da utility, digitare la stringa (senza virgolette ovviamente)

 "defaults delete ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages"

E dare invio. Il problema si risolve.

 

Spero di essere d'aiuto.

Link di questo messaggio
Condividi su altri siti
  • 5 weeks later...
Il 12/3/2019 at 16:20, Mariagrazia Cado dice:

167-761 posso proporti come sindaco di italiamac? grazie per la tua gentilezza, non é che tutti si sbattono per i novellini. Ho risolto con apple. Posto i comandi che mi hanno dato e le istruzioni che potranno servire ad altri. So che tu ne farai tesoro per aiutare. Mi hanno fatto rifare Malwarebytes che non ha trovato niente, l'avevo fatto girare ieri. Mi hanno fatto controllare "preferenze di sistema-profili" come mi avevi consigliato tu e l’avevo vuotato, in Safari-preferenze-generali, mi hanno fatto vuotare estensioni. Mi hanno fatto aprire il terminale e dare questo comando    defaults delete ~/Library/Preferences/com.apple.Safari.plist AppleLanguages    Non è successo niente!! Temevo di dover ripristinare il Mac, ho fatto il backup e ho richiamato. Ho scoperto che per la mia versione, Sierra 10.13.4 ci voleva un altro comando     defaults delete com.apple.Safari AppleLanguages

 

Grazie, grazie di tutto 😍

 

 

 

36 minuti fa, Andy Vellar dice:

Buongiorno, ma scusate, per MacOS High Sierra come mi devio comportare. Qualcuno ha i comandi da passarmi??? Sono disperato, ho chattato per un'ora e mezza con un tecnico Apple ma niente da fare....

 

Leggi quella cha scritto MariaGrazia...

Link di questo messaggio
Condividi su altri siti

Buongiorno, vi scrivo per lo stesso problema descritto sopra. Premetto che ho Mojave. Anche io ho stupidamente installato un falso Flash Player che mi ha mandato in palla safari. Aprendolo mi collegava automaticamente a "weknow.ac" e se digitavo una ricerca mi reindirizzava su Bing. Ho subito disintallato tutto, da preferenze di sistema ho cancellato i profili esistenti, ho aperto safari e ho cancellato sia le estensioni che la cache. Ho poi aperto il terminale e inserito la stringa sopra riportata riferita a Mojave. Safari funziona ma è in inglese. Qualcuno può aiutarmi? Grazie!

Link di questo messaggio
Condividi su altri siti
1 ora fa, Ester Brivio dice:

Ho poi aperto il terminale e inserito la stringa sopra riportata riferita a Mojave. Safari funziona ma è in inglese. Qualcuno può aiutarmi? Grazie!

Quella stringa cerca di andare a rimuovere un'opzione (se c'è!) nelle preferenze di Safari. Dopo averla lanciata, se non ci sono errori, bisogna riavviare il Mac. A te che messaggio ha dato in risposta dopo aver lanciato l'istruzione in Terminale?

 

Hai risolto il collegamento automatico a wekonow.ac?  Bene, allora!

 

 

Link di questo messaggio
Condividi su altri siti
  • 1 month later...
Il 10/4/2019 at 00:03, Massimo Borelli dice:

Ciao Massimo

 

Ho aperto Finder e dal menu ho cliccato su VAI --> Libreria e ho cancellato nella cartella Safari il file com.Apple.Safari.plist, dopodichè ho riavviato Safari, che è ricomparso nella sua veste iniziale, in Italiano, anche se con tutta la configurazione da rifare

Anch'io ho lo stesso problema con Safari ed ho, come te, Mojave. Ho provato a fare quanto da te suggerito, ma senza alcun risultato 😞

Hai qualche altro suggerimento?

Buon sabato

 

 

 

Il 10/4/2019 at 00:03, Massimo Borelli dice:

 

 

Link di questo messaggio
Condividi su altri siti
21 ore fa, ValentinaCru dice:

Anch'io ho lo stesso problema con Safari ed ho, come te, Mojave. Ho provato a fare quanto da te suggerito, ma senza alcun risultato 😞

Hai qualche altro suggerimento?

 

sembra che sia una preferenza da ripristinare.  Invece di cestinare files, hai provato a seguire le indicazioni di Roberto879?

Link di questo messaggio
Condividi su altri siti

Buongiorno a tutti, anche io sono incappato nello stesso malware... Sono riuscito da solo a rimuovere weknow e il resto ma ho ancora safari in inglese. Ho tentato tutte le cose che ho letto nei commenti precedenti ma ancora non sono riuscito a risolvere. Vi sarei grato se riusciste ad aiutarmi, grazie.

Mojave 10.14.5
Safari 12.11.1
 

Link di questo messaggio
Condividi su altri siti

 

Il 13/7/2019 at 12:15, aTom85 dice:

Buongiorno a tutti, anche io sono incappato nello stesso malware... Sono riuscito da solo a rimuovere weknow e il resto ma ho ancora safari in inglese. Ho tentato tutte le cose che ho letto nei commenti precedenti ma ancora non sono riuscito a risolvere. Vi sarei grato se riusciste ad aiutarmi, grazie.

Mojave 10.14.5
Safari 12.11.1

STESSO identico problema   😪 

stesso Mojave 10.14.5

Safari 12.1.1

ho provato a mettere nel Terminale la stringa di Roberto 879:

defaults delete ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages

ma non ho risolto neppure io

 

questo è quello che ho trovato su "profili" nel pannello delle preferenze

 

image.png

 

image.png.c4aa6a70703965497545e7db9a7449f5.png

 

 

ci sto impazzendo da oltre un mese, ho chiesto ad amici,  a destra e a manca, ma nessuno finora mi ha aiutato a risolvere

aiutateci..vi prego, ormai ho 76 anni e vorrei riuscirci con il vostro aiuto, anche per dire ad un mio parente, professore di scuola e che dice di essere un Dio dei mac... ma con me... non c'è riuscito,  " vedi caro  prof..... ce l'ho fatta con l'aiuto dal forum!"😂

 

Dimenticavo, se entro con un'altro utente, allora la lingua è in Italiano !

 

 

Modificato da aemme43
Link di questo messaggio
Condividi su altri siti
Il 10/4/2019 at 00:03, Massimo Borelli dice:

weknow

Visto il numero in crescita di utenti con lo stesso problema, non sarebbe il caso di chiedere a Mac Italia di sistemare la cosa, eventualmente nel prossimo aggiornamento? Siccome Mac ha come vanto il fatto di non prendere virus, ne va anche della loro immagine e noi eviteremmo di smanettare a caso su questo problema. Grazie

Link di questo messaggio
Condividi su altri siti

Salve io ho risolto su macOS Mojave 10.14.5 in questa maniera:

  1. Chiudete Safari
  2. andate nella certella /Users/$USER/Library/Containers/com.apple.Safari/Data/Library/Preferences/
  3. cancellate il filecom.apple.Safari.plist
  4. riaprite Safari, e lo ritroverete in lingua ITALIANA

Fatemi sapere se tutto è andato bene.

 

  • Love 1
Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo