Vai al contenuto





oyster18

Installazione scheda grafica owc Radeon RX 580

Recommended Posts

Salve a tutti!

Posseggo un Mac Pro metà 2010 nehalem e volendolo potenziare ho appena acquistato la scheda grafica in oggetto.

Ho semplicemente tolto quella originale ed inserito la nuova ma Mac os non parte... Anzi, parte in automatico Windows che tengo installato in altro hard disk interno. Secondo voi quale può essere il problema? Mancanza driver o altro? Grazie

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


16 minuti fa, Carolus73 dice:

Hai connesso correttamente il cavo in dotazione?

penso di si. Nella scatola c'era un cavo con doppio connettore da collegare alla motherboard, in luogo dell'originale con un solo spinotto. Dall'altro capo uno spinotto 8 pin da collegare alla scheda grafica.

Tieni presente che, come avevo scritto sopra, la macchina, all'accensione, dopo circa un minuto di scermo nero è partita in automatico avviando windows! Quindi la scheda funzionerebbe (che tristezza vedere apparire il logo win! Ma come... win la legge e mac os no? Non ci voglio credere!)

Modificato da oyster18
Precisazioni

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
6 ore fa, @Maurizio dice:

Che versione di OS X hai ?

10.13.6 osx High sierra

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
22 minuti fa, oyster18 dice:

Adesso provo

Niente non parte schermo nero. Anzi stavolta noto che le due ventole della scheda grafica partono appena accendo il Mac ma dopo qualche secondo si fermano

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
9 minuti fa, oyster18 dice:

Niente non parte schermo nero. Anzi stavolta noto che le due ventole della scheda grafica partono appena accendo il Mac ma dopo qualche secondo si fermano

E dopo un minuto circa è partito di nuovo Windows ma le ventole della scheda grafica sempre ferme

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

La descrizione sul sito di Amazon non è chiarissima, ma potrebbe darsi che la scheda non sia supportata da OS X precedenti a Mojave ?

Modificato da @Maurizio

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, @Maurizio dice:

La descrizione sul sito di Amazon non è chiarissima, ma potrebbe darsi che la scheda non sia supportata da OS X precedenti a Mojave ?

 

Leggendo la descrizione, come dice il produttore installando questa GPU si ottiene la possibilità di installare anche l'ultimo macOS Mojave, quindi penso sia compatibile anche con i precedenti...

 

Nelle note OWC aggiunge alcuni dettagli riguardo la schermata nera ed il fatto di non riuscire ad utilizzare lo Startup Manager - Supporto Apple

 

@oyster18

 

backup dell'attuale sistema operativo e successivo aggiornamento a macOS Mojave?

Modificato da AntoninoBattiato

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ciao, è normale che la non vedi il boot screen con una gpu non uscita in principio con il Mac Pro. Bisogna flashare il bios.
Prova a rimontare la vecchia scheda e cambia la priorità di boot, da windows a Mac OS. Poi rimonta la radeon.

Oppure togli l'hard disk con windows.

Prova a fare questi passaggi

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 31/7/2019 at 21:35, oyster18 dice:

Salve a tutti!

Posseggo un Mac Pro metà 2010 nehalem e volendolo potenziare ho appena acquistato la scheda grafica in oggetto.

Ho semplicemente tolto quella originale ed inserito la nuova ma Mac os non parte... Anzi, parte in automatico Windows che tengo installato in altro hard disk interno. Secondo voi quale può essere il problema? Mancanza driver o altro? Grazie

Da quello che ho letto durante la conversazione tu hai high sierra (Quindi immagino che anche tu abbia installato il firmware 2010 per poter installare i processori della serie Gulftown). Ti confermo che i driver sono già installati di default nel sistema.

Vedo che il kit che ti fornisce la OWC consiste in una scheda XFX RX 580 con 8GB di ram e l'apposito cavetto.

Teoricamente dovrebbe funzionare.

Io ti sto scrivendo proprio da un Mac Pro del 2009 con High Sierra e una Radeon RX 580 Pulse da 8GB della Sapphire (è considerato il modello con la massima compatibilità perché è lo stesso del kit esterno che vendeva la Apple non troppo tempo fa). Il cavetto di collegamento l'ho comprato in Cina.

Come vedi nel mio caso funziona tutto perfettamente.

È normale che tu veda la schermata nera di avvio quando premi il tasto alt. Non preoccuparti per questo.

Per essere sicuro di riavviare in Mac OS non ti resta che resettare la PRam; qui sul sito Apple viene spiegato come: https://support.apple.com/it-it/HT204063

Vedrai che il Mac ripartirà da Mac OS.

Mi raccomando: togli tutte le altre schede grafiche (eccetto la RX580). Sembra che faccia qualche casino soprattuto se si mescolano le Nvidia e le AMD (ricordati poi che da Mojave le Nvidia non hanno i driver). Eventualmente togli anche il disco che contiene windows. Lascia solo Mac OS.

Altra cosa da ricordare: per qualche strano motivo (forse un bug della serie 2009 dei MacPro) quando avvii il sistema le ventole della scheda grafica a un certo punto inizieranno a partire con rumore stile elicottero. Esiste una soluzione molto semplice: avvia un programma come ad esempio Heaven che trovi qui: https://benchmark.unigine.com/heaven

che ti farà partire alle stelle le ventole ma dopo un po' le sentirai calmarsi ma non troppo (questione di un minuto). Esci dal programma e noterai un ulteriore abbassamento a normalissimi livelli.

In pratica il Mac non riesce ad aggiustare le ventole della scheda a meno che, in qualche momento, non le si faccia andare a manetta. Da lì in poi le gestisce in modo corretto.

Si tratta veramente di perderci al massimo un paio di minuti.

 

 

Modificato da Legs

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo