Vai al contenuto





antpicc

Notifica continua aggiornamento Command Line Tools per XCode 11.10

Recommended Posts

Salve a tutti. Ieri ho aggiornato il mio OS a Catalina. Dopodiché, ho provato a usare Photorec ma l'applicazione, che fino al giorno prima aveva funzionato benissimo, stavolta non andava. Cercando sul web, ho visto che una possibile soluzione era installarla direttamente dal terminale, col comando:

brew install testdisk

Dal momento che il comando brew non era riconosciuto, e di nuovo dopo essermi documentato sul web, ho visto che una possibile soluzione poteva consistere nel dare da terminale il seguente comando:

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null

Dopo aver fatto andare il comando mi è comparsa la notifica di aggiornamento disponibile che vedete nella foto allegata (non so se le due cose sono legate, penso di si). Ho provato più volte a fare andare l'aggiornamento, con due esiti: (1) o l'aggiornamento termina, ma dopo poco mi ricompare la notifica per lo stesso aggiornamento oppure (2) mi compare un alert che dice che l'aggiornamento non è andato a buon fine.
Intanto, ho risolto la questione Photorec, nel seguente modo. Ho dato il comando

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Dopodiché, ho dato il comando

brew install testdisk

Adesso Photorec funziona alla perfezione, ma continuo ad avere la fastidiosa notifica di aggiornamento. Come posso risolvere? (Spero di non aver fatto un casino)

Schermata 2019-10-09 alle 11.44.06.png

Modificato da antpicc

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


27 minuti fa, Giacomo Antolini dice:

Ho lo stesso tuo problema con quell'aggiornamento di Xcode.

 

Anche io uso homebrew e dopo l'upgrade l'ho rimosso e reinstallato.

 

Non ho ancora trovato una soluzione. Tu?

Io tecnicamente non posso rimuovere Xcode perché non mi risulta nelle App...ottimo! Infatti, se provo da terminale

xcode -version

mi esce

xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

Ottimo ancora! Come hai disinstallato Homebrew? [Comunque un macello sto Catalina...]

Modificato da antpicc

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo