Vai al contenuto





Jeppy

Problema sconosciuto MacBook Pro Mid 2009

Recommended Posts

Ciao a tutti,

 

avrei bisogno del vostro aiuto per capire i motivi dietro ad alcuni problemi che un MacBook Pro 15 pollici (Mid 2009) ha iniziato a darmi qualche mese fa, ovvero iniziare a spegnersi all'improvviso e senza apparente motivo.

Facendola breve ho controllato quanti più aspetti possibili sulla base delle mie capacità e non ho trovato problemi alla batteria, ne al disco rigido (sia fisicamente che da un punto di vista di integrtià dei dati, permessi, ecc) secondo vari software (Utility disco, Onyx, CoconutBattery, ecc). 

Il computer è perfettamente pulito e infatti resta sempre nel range di temperature corrette (o comunque che ha sempre tenuto dall'acquisto) ma, nonostante questo, alle volte decide di spegnersi.

Puo succedere sia quanto sta acceso senza che nessuno lo usi, oppure mentre trasferisce dei dati (per esempio backup di time machine), oppure navigando su internet, oppure quanto la temperatua sale guardando youtube a risoluzione alta (per i suoi standard) oppure resta acceso per ore senza problemi (🙄).

L'unica costante è che, una volta spento all'improvviso, si avvia due volte con il primo boot che dura una frazione di secondo (un po come quando si resetta la sdram).

 

Ho provato come ultima istanza il vecchio "Test Hardware" che veniva fornito sul DVD all'interno della scatola, il quale ha dato i seguenti responsi altalentanti:

 

- Trovato errore cod: 4MEM/9/40000000: 0xa9d0bd18

- Trovato errore cod: 4MEM/4/40000000: 0xa9d6ed18

- Trovato errore cod: 4MEM/4/40000000: 0xa9d06d18

 

Questi risultati si sono alternati diverse volte a seguito delle diverse prove che ho fatto, salvo una volta in cui non ne ha rilevati proprio: tra i vari test ho anche provato a smontare i banchi di RAM invertendoli a turno per vedere se uno potesse essere il problema.

 

Ho provato a cercare qui codici su internet, ma senza successo, mentre all'Apple Store mi hanno detto essere un prodotto obsoleto, dunque non avrebbero saputo aiutarmi (forse qualche reseller autorizzato a cui "scaricano" i prodotti vecchi).

 

Qualcuno di voi ha idea di cosa possa essere e come venirne a capo?

Grazie per il vostro tempo!

 

Ciao

Modificato da Jeppy

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


Purtroppo Apple ha smesso di dare supporto ai nostri vecchi Mac, sia a livello hardware che software. Non ti resta altro che fare delle prove.

Da come hai descritto il problema, temo proprio che è la scheda madre che se ne stà andando.

Però, prima di essere certi di questo, potresti, magari, provare a cambiare la RAM con 2 banchi nuovi, per escludere il problema RAM. Altrimenti, potresti provare a usare una scheda grafica alla volta (con gfxCardStatus, cambiando da GPU Dedicata a Integrata e viceversa), per vedere se magari non è un problema GPU.

Hai per caso avuto schermate grigie, sfarfallii, kernel panic o linee verdi sul monitor, per caso? 

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
7 ore fa, EmyOSX dice:

Purtroppo Apple ha smesso di dare supporto ai nostri vecchi Mac, sia a livello hardware che software. Non ti resta altro che fare delle prove.

Da come hai descritto il problema, temo proprio che è la scheda madre che se ne stà andando.

Però, prima di essere certi di questo, potresti, magari, provare a cambiare la RAM con 2 banchi nuovi, per escludere il problema RAM. Altrimenti, potresti provare a usare una scheda grafica alla volta (con gfxCardStatus, cambiando da GPU Dedicata a Integrata e viceversa), per vedere se magari non è un problema GPU.

Hai per caso avuto schermate grigie, sfarfallii, kernel panic o linee verdi sul monitor, per caso? 

 

 

Eh me ne sono accorto, e non sarei nemmeno contrario data l'età della macchina (non pretendo una riparazione), ma i codici d'errore ancora li hanno quindi almeno capire cosa significano mi sembrerebbe corretto.

 

Riguardo il software che mi hai consigliato, beh ti ringrazio perchè non lo conoscevo, ma dubito mi possa essere utile: il macbook in questione è giusto l'ultimo modello prima che si passasse alla doppia scheda video integrata+dedicata. 😅

Non ricordo di aver mai notato i problemi di cui parli, ma posso dire che il problema è nato poco dopo aver usato il computer per montare ed esportare diversi video: non sto dicendo che sia stato questo, ma comunque si è preso delle belle scaldate che, a 10 anni, magari non gli hanno giovato 😂

Direi che le alte temperature sono quello che potrebbe rompere le balle, ma purtroppo non posso dirlo con sicurezza non essendo una costante...😔

Per quanto riguarda infine la RAM, non so se vale la pena che vada a cercare dei banchi così vecchi solo per fare una prova: ho provato ad invertire quelli che ho e anche usarne solo 1 alla volta, ma non è emerso nulla di particolare...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
10 ore fa, Jeppy dice:

 

Eh me ne sono accorto, e non sarei nemmeno contrario data l'età della macchina (non pretendo una riparazione), ma i codici d'errore ancora li hanno quindi almeno capire cosa significano mi sembrerebbe corretto.

 

Riguardo il software che mi hai consigliato, beh ti ringrazio perchè non lo conoscevo, ma dubito mi possa essere utile: il macbook in questione è giusto l'ultimo modello prima che si passasse alla doppia scheda video integrata+dedicata. 😅

Non ricordo di aver mai notato i problemi di cui parli, ma posso dire che il problema è nato poco dopo aver usato il computer per montare ed esportare diversi video: non sto dicendo che sia stato questo, ma comunque si è preso delle belle scaldate che, a 10 anni, magari non gli hanno giovato 😂

Direi che le alte temperature sono quello che potrebbe rompere le balle, ma purtroppo non posso dirlo con sicurezza non essendo una costante...😔

Per quanto riguarda infine la RAM, non so se vale la pena che vada a cercare dei banchi così vecchi solo per fare una prova: ho provato ad invertire quelli che ho e anche usarne solo 1 alla volta, ma non è emerso nulla di particolare...

Leggendo le caratteristiche tecniche, il tuo Mac dovrebbe avere 2 schede grafiche, la Geforce 9400M (integrata) e la Geforce 9600M GT (dedicata). Non è quindi diverso dal primo Macbook Pro Unibody da 15" che avevo nel 2008.

Ad ogni modo, su vari siti Apple ho letto che la Geforce 9600M GT tende a scaldarsi parecchio. E che, con il tempo, la saldatura sulla scheda madre, dove ci sono tutti i contatti saldati delle 2 GPU, tende a bruciarsi completamente, causando crash e Kernel Panic.

C'è poco, quindi, che puoi fare.

Se sei abbastanza pratico, proverei a smontare il Mac, pulire le ventole per bene, e passare un po' di pasta termica sui chipset delle 2 GPU.

Su ifixit dovresti trovare la guida completa.

Prova a fare così è vedi se, magari, il problema si attenua un po'.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 15/1/2020 at 20:18, EmyOSX dice:

Leggendo le caratteristiche tecniche, il tuo Mac dovrebbe avere 2 schede grafiche, la Geforce 9400M (integrata) e la Geforce 9600M GT (dedicata). Non è quindi diverso dal primo Macbook Pro Unibody da 15" che avevo nel 2008.

Ad ogni modo, su vari siti Apple ho letto che la Geforce 9600M GT tende a scaldarsi parecchio. E che, con il tempo, la saldatura sulla scheda madre, dove ci sono tutti i contatti saldati delle 2 GPU, tende a bruciarsi completamente, causando crash e Kernel Panic.

C'è poco, quindi, che puoi fare.

Se sei abbastanza pratico, proverei a smontare il Mac, pulire le ventole per bene, e passare un po' di pasta termica sui chipset delle 2 GPU.

Su ifixit dovresti trovare la guida completa.

Prova a fare così è vedi se, magari, il problema si attenua un po'.

Il modello che citi tu è quello immediatamente successivo, mentre nel mio c'è solo la 9400M, e l'ho preso giusto 2 mesi prima l'uscita di quelli nuovi, non senza soddisfazione data all'aumento di prezzo e dei problemi che sono sorti (per lo meno all'inizio) proprio nella gestione delle due schede video.

Per quanto riguarda lo smontaggio avrei anche la manualtià per farlo, anzi l'ho anche già  fatto, ma mi prima di metterci mano mi piacerebbe capire cosa significano i codici che ho inserito nel primo post, i quali magari danno già un indicazione sul problema ed il da farsi.

Davvero non esiste un sito che raggruppa tutti questi codici di errore? O un modo per risalrci?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ho dato un'occhiata su diversi siti ho trovato la risposta che la ram difettosa ,questo era l'articolo.MB SR errore 4MEM/9/40000000. questo è l'indirizzo.https://www.macitynet.it/forum/topic/64038-mb-sr-errore-4mem940000000/

https://www.imaccanici.org/forum/viewtopic.php?t=44489

Modificato da giubboni

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, giubboni dice:

ho dato un'occhiata su diversi siti ho trovato la risposta che la ram difettosa ,questo era l'articolo.MB SR errore 4MEM/9/40000000. questo è l'indirizzo.https://www.macitynet.it/forum/topic/64038-mb-sr-errore-4mem940000000/

https://www.imaccanici.org/forum/viewtopic.php?t=44489

Proprio come immaginavo.

Non è che, magari, hai a portata di mano 2 banchi nuovi?

Vero che 2 banchi da 2-4 GB costano quasi niente, oggi. Però, senza doverli ad andare a comprare, magari se c'è li hai già a portata di mano e' ancora più conveniente.

Comunque, lo stesso problema della RAM, nonché della GPU integrata, l'ho avuto anch'io, sia sull'Unibody 2008 con doppia GPU (che comunque, per 2 anni ha funzionato lo stesso bene, cambiando soltanto la RAM e portandola a 8 GB), che anche con il mio 17" del 2010, che ancora uso.

Il problema non è tanto delle GPU di per se, ma dei contatti sulla scheda madre che saltano non appena fai qualcosa di pesante che surriscalda il Mac.

Pensa che quando ho portato in assistenza il mio 17", 2 mesi dopo averlo acquistato, quelli dell'Apple Store di Milano mi hanno detto che avevano trovato i contatti praticamente saltati e bruciati. Tanto che mi hanno dovuto cambiare l'intera scheda madre, oltre la RAM e il cavo dell'LCD.

E non è che facevo chissà cosa. Solo un po' di editing video leggero con Final Cut 7. Però,  sono rimasto quasi un mese senza Mac, perché buona parte delle schede madri che avevano sia per il 17" che per il 15" (stessa configurazione) erano quasi tutte difettose di fabbrica. Meno male che avevo ancora la garanzia e l'Apple Care. Sennò mi sarebbe davvero dispiaciuto aver speso tanti soldi per niente.

Comunque, adesso, nonostante i suoi 10 anni, devo dire che ancora funziona bene. Però, ormai, lo uso solo per editing audio per progetti di lavoro e basta.

I lavori più pesanti, come editing video e altro, ormai da 3 anni li faccio con un assemblato che mi sono fatto. 

 

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 17/1/2020 at 18:19, giubboni dice:

ho dato un'occhiata su diversi siti ho trovato la risposta che la ram difettosa ,questo era l'articolo.MB SR errore 4MEM/9/40000000. questo è l'indirizzo.https://www.macitynet.it/forum/topic/64038-mb-sr-errore-4mem940000000/

https://www.imaccanici.org/forum/viewtopic.php?t=44489

Grazie mille, non ero riuscito a trovare nulla e invece.. 😅

 

Il 17/1/2020 at 20:46, EmyOSX dice:

Proprio come immaginavo.

Non è che, magari, hai a portata di mano 2 banchi nuovi?

Vero che 2 banchi da 2-4 GB costano quasi niente, oggi. Però, senza doverli ad andare a comprare, magari se c'è li hai già a portata di mano e' ancora più conveniente.

Comunque, lo stesso problema della RAM, nonché della GPU integrata, l'ho avuto anch'io, sia sull'Unibody 2008 con doppia GPU (che comunque, per 2 anni ha funzionato lo stesso bene, cambiando soltanto la RAM e portandola a 8 GB), che anche con il mio 17" del 2010, che ancora uso.

Il problema non è tanto delle GPU di per se, ma dei contatti sulla scheda madre che saltano non appena fai qualcosa di pesante che surriscalda il Mac.

Pensa che quando ho portato in assistenza il mio 17", 2 mesi dopo averlo acquistato, quelli dell'Apple Store di Milano mi hanno detto che avevano trovato i contatti praticamente saltati e bruciati. Tanto che mi hanno dovuto cambiare l'intera scheda madre, oltre la RAM e il cavo dell'LCD.

E non è che facevo chissà cosa. Solo un po' di editing video leggero con Final Cut 7. Però,  sono rimasto quasi un mese senza Mac, perché buona parte delle schede madri che avevano sia per il 17" che per il 15" (stessa configurazione) erano quasi tutte difettose di fabbrica. Meno male che avevo ancora la garanzia e l'Apple Care. Sennò mi sarebbe davvero dispiaciuto aver speso tanti soldi per niente.

Comunque, adesso, nonostante i suoi 10 anni, devo dire che ancora funziona bene. Però, ormai, lo uso solo per editing audio per progetti di lavoro e basta.

I lavori più pesanti, come editing video e altro, ormai da 3 anni li faccio con un assemblato che mi sono fatto. 

 

 

Purtroppo no, vedrò di attrezzarmi e fare qualche prova!

Intanto grazie a tutti per il supporto! 🍻

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo