Vai al contenuto

Benvenuto nella community di Italiamac Forum

Guest Image

Benvenuto su Italiamac, la più grande comunità AMUG italiana riconosciuta da Apple. La consultazione è libera. Se vuoi anche partecipare attivamente alle discussioni pubblicando post e messaggi puoi iscriverti gratuitamente, avrai molti vantaggi:

  • Pubblicare post, messaggi e richieste di aiuto
  • Fare amicizia e usare i messaggi privati fra utenti
  • Pubblicare annunci di vendita di usato
  • Usare tutte le funzioni della community

ISCRIVITI GRATIS


Change Mode






Quale osx su macbook unibody late 2009?


Recommended Posts

Buongiorno sono in possesso di un MacBook unibody late 2009 al quale ho aumentato la RAM a 8 gigabyte e messo un SSD Samsung da 500 gigabyte. Vorrei aggiornare il sistema operativo facendo una installazione pulita. Fino ad oggi avevo ancora il vecchio Snow Leopard. Ho visto che per il mio modello l'ultimo OSX compatibile è High Sierra. Secondo voi mi conviene installare questo o optare per qualche sistema un po' meno recente tipo el capitan o Yosemite? In modo da rendere il PC più performante. Ma se non sbaglio è proprio anche si era l'ultimo sistema operativo supportato da aggiornamenti Apple.

Cosa cosa mi consigliate di fare?

Link di questo messaggio
Condividi su altri siti

Sierra, stabile, aggiornato per gli usi odierni e ancora non stressante per la CPU. Per esempio un piccolo vantaggio su El Capitan. Se usi Mail non hai problemi con le PEC di Aruba, cosa che ti è invece impossibile con El Capitan.

Link di questo messaggio
Condividi su altri siti

si metti l'ultimo disponibile. Ricorda di inizializzare il disco se vieni da snow leopard. Non fare upgrade

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti
2 minuti fa, dr.virus93 dice:

si metti l'ultimo disponibile. Ricorda di inizializzare il disco se vieni da snow leopard. Non fare upgrade

Si grazie per forza anche perché non me lo fa eseguire. Ho il problema di non riuscire a fare la usb di avvio. Sono riuscito a scaricare high Sierra tramite la patch duosdude1 ma il disco di avvio da usb non riesco. Le app per creare la usb non supportano snow Leopard

 

  • Non mi piace 1
Link di questo messaggio
Condividi su altri siti

Qualche consiglio rapido. 1 - come già ti hanno detto, inizializza , la cosa migliore da fare quando si installa un sistema operativo molto più avanzato. 2 - se non hai necessità particolari, sull’unibody meglio Sierra  Te lo dico anche per esperienza diretta. Ho un unibody 2010 con 16gb, con Sierra era un po’ più reattivo e operava con temperature un filo più basse. 3 - se non hai la dannata pennetta bootable (quella scaricata per la patch di solito non va bene) porta il computer da qualcuno che  le ha, invece di incasinarti in tentativi che ti faranno perdere una marea di tempo e senza la certezza del risultato. Poche decine di euro, meno di cinquanta, e torni a casa con un bel computer pronto come si deve.

Link di questo messaggio
Condividi su altri siti
4 ore fa, fabrizio gabellone dice:

Si grazie per forza anche perché non me lo fa eseguire. Ho il problema di non riuscire a fare la usb di avvio. Sono riuscito a scaricare high Sierra tramite la patch duosdude1 ma il disco di avvio da usb non riesco. Le app per creare la usb non supportano snow Leopard

 

 

C'è anche la guida per crearla da terminale, cercala su google

Mors Tua Vita Mea

Link di questo messaggio
Condividi su altri siti
3 ore fa, bros720 dice:

Qualche consiglio rapido. 1 - come già ti hanno detto, inizializza , la cosa migliore da fare quando si installa un sistema operativo molto più avanzato. 2 - se non hai necessità particolari, sull’unibody meglio Sierra  Te lo dico anche per esperienza diretta. Ho un unibody 2010 con 16gb, con Sierra era un po’ più reattivo e operava con temperature un filo più basse. 3 - se non hai la dannata pennetta bootable (quella scaricata per la patch di solito non va bene) porta il computer da qualcuno che  le ha, invece di incasinarti in tentativi che ti faranno perdere una marea di tempo e senza la certezza del risultato. Poche decine di euro, meno di cinquanta, e torni a casa con un bel computer pronto come si deve.

Ok grazie mille farò come dici. Ho sbattuto fin troppo senza riuscirci nemmeno da terminale. 

P.s. : hai provato mojave o Catalina sul tuo unibody?

  • Non mi piace 1
Link di questo messaggio
Condividi su altri siti

Sull’unibody no, puoi mettere fino a High Sierra. Per farlo occorre ricorrere alla patch, ma trovo non abbia senso. Se hai una necessità particolare che ti obbliga ai MacOS più recenti capisco, ma dato che nella stragrande maggioranza dei casi non c’è , non ne vedo la necessità. Mojave , e men che mai Catalina, non portano alcun vantaggio a un unibody.

Link di questo messaggio
Condividi su altri siti

Come non riesci a creare la USB... dal terminale in root

 

(Non ricordo se il percorso è questo ma verifica)

/Application/InstallMacOSX/Content/MacOS/

 

 

esegui il file createInstallMedia

./createInstallMedia --volume /Volumes/USB && sync

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti
5 ore fa, dr.virus93 dice:

Come non riesci a creare la USB... dal terminale in root

 

(Non ricordo se il percorso è questo ma verifica)

/Application/InstallMacOSX/Content/MacOS/

 

 

esegui il file createInstallMedia

./createInstallMedia --volume /Volumes/USB && sync

Che file system mi conviene usare? Il nuovo Apfs o MacOs esteso journaled?

Link di questo messaggio
Condividi su altri siti
Il 29/10/2020 at 15:01, fabrizio gabellone dice:

Che file system mi conviene usare? Il nuovo Apfs o MacOs esteso journaled?

Mac OS Esteso se riesci

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti

io possiedo un macbookpro 15' di metà 2009 ..da leopard sono passato a el capitain e chiaramente un pò di rallentamento lo ho avuto.

da oltre 2 anni ho sostituito l'HHD con SSD e aggiunto RAM e onestamente è tornato quasi come all'inizio.

mi sento di consigliare al capitain

 

  • Non mi piace 1
Link di questo messaggio
Condividi su altri siti
Il 5/11/2020 at 01:57, J.T.Kirk dice:

Da Snow Leopard non si può creare la chiavetta avviabile da terminale.

 

 

Perchè no? Certo che può

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti
1 ora fa, dr.virus93 dice:

Perchè no? Certo che può

 

Se lo fai da Snow Leopard ottieni:

createinstallmedia: command not found

 

Si può fare da Utility Disco (complicato) o con applicazioni terze.

 

-Con Diskmaker X usando una delle vecchie versioni compatibili con SL.

https://diskmakerx.com/download/

 

 

 

Modificato da J.T.Kirk

"Le menti non sono vasi da riempire ma fuochi da accendere" - Plutarco

Link di questo messaggio
Condividi su altri siti
4 ore fa, J.T.Kirk dice:

 

Se lo fai da Snow Leopard ottieni:

createinstallmedia: command not found

 

Si può fare da Utility Disco (complicato) o con applicazioni terze.

 

-Con Diskmaker X usando una delle vecchie versioni compatibili con SL.

https://diskmakerx.com/download/

 

 

 

se ottieni command not found significa che stai digitando male il comando. Non c'entra nulla la versione di Mac OS, alla fine sotto è Linux, il ./ significa (in bash) esegui (.) il / serve per concatenare quindi ./ ==> execute in same dir

 

è letteralmente impossibile che non funziona

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti

sarebbe quindi

su -

cd /Application

cd InstallMacOS/Content/blah/

./createInstallMedia --volume /Volumes/USB && sync

 

Il tool che vai ad utilizzare non fa altro che utilizzare questo comando, dando una GUI per gli utenti che non sanno neanche cosa sia il terminale. Se non trovi la versione per la 10.6 significa che non c'è, ma non è detto che non funzioni il comando...

Modificato da dr.virus93

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti

Che lo script dia errori lo accetto, ma command not found no :)

Ora precisamente non ricordo, ma sono sicuro che il modo c'è. Lo feci anni fa passando da snow leopard a Mountain Lion

iMac 21.5 1TB HD 8GB Ram ddr3 1333 Mhz ; Macbook 2007 320GB HD 2GB RAM 667Mh; iPod Shuffle 3th Generation 1GB

Link di questo messaggio
Condividi su altri siti

Rispondi e partecipa alla discusione

Puoi rispondere subito e iscriverti successivamente. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo