Vai al contenuto





Archived

Questa discussione è archiviata e chiusa a future risposte.

Enrico Caddeo

Ancora un aiuto con JAVA e l'ambiente JDK!

Recommended Posts

Salve a tutti, dopo moltissime richieste d'aiuto per la programmazione Java, spero che questa volta possiate aiutarmi...

... vorrei iniziare a programmare in Java (sono un neofita!) col mio iMac G5 ma non ho ancora capito quale è l'ambiente per farlo!!!

Ho comprato un libro che spiega come scaricare ed installare il JDK ma non esiste per OS X.......... cosa devo usare?

Vi prego di aiutarmi perchè mi serve per lo studio e non voglio credere che devo rispolverare il mio vecchio PC winzzoz per scrivere 2 righe di codice!!!

Grazie

Enrico

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti


Con ordine:

Per programmare non necessiti forzatamente di un ambiente anche se questo ti aiuterebbe molto in caso di grandi progetti (leggi il thread su eclipse sempre su questo indice).

Basterebbe solamente un editor di testo ed il compilatore java (javac della gnu).

Passiamo alle JDK:

Di default c'e` la 1.4.2 ma se inizi adesso a programmare ti consiglio di usare la 1.5 che ha tante cose in piu` e tante migliorie.

Scarichi la versione per mac dal sito per developer di apple dove trovi il package.

Per avere javac il metodo piu` semplice e` installare il pacchetto per sviluppatori che c'e` nel cd anche se puo` risultare datato, altra soluzione sarebbe installarlo dai dports (java/javacc), a te la scelta.

Accorgimenti:

Qualsiasi cosa tu usi per scrivere/sviluppare/lanciare i tuoi programmi devi sempre specificare di usare la versione 1.5 altrimenti sono dolori.

In definitiva:

Consiglio Eclipse come piattaforma, e` molto facile da usare, per java credo sia il top e non da` problemi nello scegliere le varia jdk installate.

Su http://developer.apple.com/ c'e` la JSE 5.0 alla release 4, prendi quella ed installala.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Caro amico, sei un grande!

Non mi avevano ancora risposto così chiaramente!

Posso farti un altra domanda per essere sicuro?

Coreggimi se sbaglio:

1_ scarico eclipse-SDK-3.1.1-macosx-carbon.tar.gz (dal sito eclipse.org);

2_ scarico la JDK che mi hai detto tu proprio alla fine del tuo messaggio;

3_ ed ora posso iniziare il mio corso di Java seguendo qualsiasi libro (ne ho uno della Mc Groeill... non mi ricordo come si scrive!) per fare i primi passi??????

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ops! Ma cosa mi sta chiedendo?

Come clicco sul download del JDK nel sito degli sviluppatori, mi manda in questa pagina: "Developper connection-Member Site"........ mi chiede il login... ma non sono registrato!!!!

Non è che devo registrarmi da qualche parte per scaricare?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Scarichi JDK ed eclipse ed installi le due cose.

Per dire ad Eclipse di usare la JSE 5 basta andare nelle preferenze, dopo averla installata, sotto la voce JAVA e poi compiler.

Un appunto sul libro, quello che stai usando della McGraw-Hill e` un buon libro (se quello diviso in due libri: fondamenti e tecniche avanzate).

Fai attenzione pero` c'e` in giro ancora quello per 1.4 mentre io ti consiglio di prendere direttamente quello per java 5, in modo che non impari cose che non verranno piu` utilizzate tra non molto...

Avvertenza: il libro originale aggiornato alla 1.5 costa un abbisso (60+ euro spedizioni incluse), se hai la pazienza di aspettare qualche mese la McGraw dovrebbe stampare la versione ridotta (e di conseguenza piu` economica) del libro aggiornato, i contenuti sono i medesimi ma stampati piu` in piccolo.

Dai un occhio su ibs e mcgraw italia quello ridotto costa intorno ai 15 euro.

Magari per il momento studia su quello che hai ed integra con le javadoc fino all'uscita del libro mignon, a meno che, ovviamente, non abbia voglia di spendere tutti quei soldi subito.

Buono studio!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

grazie 10000!

Posso contattarti in futuro per illuminarmi sulla programmazione java?

Sei stato un grande!

Ora mik sono appena iscritto al sito degli sviluppatori ed ho appena scaricato eclipse...... ti terrò aggiornato sui miei passi!

Per ora grazie ancora

Enrico

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Bel problema, java 5 non credo che uscira` per panter, mi sa che ti dovrai accontentare della 1.4.x se vuoi continuare a sviluppare su quel sistema.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ho trovato qualcosa inierente a Panter ma il nome del file da scaricare non è = a quello che mi hai dato tu!

Infatti è:

Java 1.4.2 Update 1 Developer Tools (Panther)

Developer Tools package for Java 1.4.2 Update 1 for Mac OS X Panther (v10.3). Contains new documentation, J2SE source code, Xcode project templates, and Java tools.

é giusto?

Io provo a scaricarlo!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Se hai il pc aggiornato a dopo Agosto 2004 allora quella roba la hai gia` nel tuo sistema ed e` inutile scaricarla.

/Applications/Utilities/Java/ Dovrebbe essere qui dentro, vedi se te la ritrovi prima di scaricarla inutilmente.

E` la JSE 1.4, la vecchia.

Le cose da fare sono 3:

Te le elenco in ordine di convenienza (a mio parere)

1. Installare Tiger e JSE 5.0

2. Usare altro OS e programmare in 5.0

3. Programmare in 1.4.x sotto Panter

A te la scelta.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Se hai il pc aggiornato a dopo Agosto 2004 allora quella roba la hai gia` nel tuo sistema ed e` inutile scaricarla.

/Applications/Utilities/Java/ Dovrebbe essere qui dentro, vedi se te la ritrovi prima di scaricarla inutilmente.

E` la JSE 1.4, la vecchia.

Le cose da fare sono 3:

Te le elenco in ordine di convenienza (a mio parere)

1. Installare Tiger e JSE 5.0

2. Usare altro OS e programmare in 5.0

3. Programmare in 1.4.x sotto Panther

A te la scelta.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

La nuova ha molte funzionalita` in piu` e tutti sicuramente useranno presto o tardi queste aggiunte/modifiche, ed utilizzare una JDK vecchia vuol dire non riuscire a compilare i programmi che ne fanno uso.

Scrivere con la vecchia non vuol dire perdere pero` compatibilita` in quanto i programmi scritti per 1.4.X sono compilabili anche su 1.5 .

Dal mio modo di vedere e` utile programmare in 1.5 e iniziare a fare l'occhio alle novita` che ci sono, io ne ho usate molte in un progetto e francamente sono un bel passo in avanti (ovviamente non conosco tutte le differenze tra le due versioni ma sul sito della sun sicuramente troverai info in quantita` industiale) , ma sicuramente programmare in 1.4 non e` certo un dramma.

Fossi in te rifletterei sull'importanza che ha java per te e sulla necessita` di stare legato a panther.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

×
×
  • Crea Nuovo...

Info

Per offrirti il miglior servizio possibile il sito utilizza cookies, anche di terze parti e profilazione. Utilizzando il sito acconsenti al loro impiego. Privacy Policy Termini di utilizzo